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LOGOMOTION

INTRODUCTION

What LogoMotion Is

LogoMotion is & 3D flying togo tool that turns your
computer screen into a synthetic, three-dimensional
World. This 3D World has real properties - height,
width, depth, and (in the sense of animation) time.
You will learn how to create flying logos and exciting
animations using a variety of tools, all within this 3D
World. This manual is designed to help you work in
3D as easily as possible, while having fun.

You don’t have to be a rocket scientist to use
LogoMotion, although if you are one, you'll have as
much fun as anyone else. LogoMotion exists, in part,
because so much 3D software tends to be
intimidating and it’s no fun to use a program that’s
hard to control.

What LogoMotion Is Not

LogoMotion is not an expensive, complicated
animation package. It offers a specific feature set
that is streamlined for creating animated 3D flying
logos and presentations.

LogoMoation is not “instant 3D.” It's as close as you
can get, but be prepared to spend some time
building, fine-tuning, and rendering your 3D wark.
By nature, 3D graphics are quite complex (far more
complicated than their 2D equivalents), and creating
them can be slow. LogoMotion gives you speedy
and intuitive 3D. We've done a good job of making it
simple, but there's a great deal going on behind the
scenes. Be aware, too, that creating complex
scenes may push the limits of your particular
system. But LogoMotion will let you create
animations that would have required the use of a
very expensive workstation only a few years ago.




MetaCreations License Agreement

This license agreement is a legal agreement between you, the end user, and MetaCreations Corporation. It is a license
agreement and not an agreement for sale. Please read this license agreement carefully. If you do not agree with the terms and
conditions of this agreement, promptly return the package unopened to the place you obtained it and your money will be
refunded.

MetaCreations Software License

1) License

This software can only be used on a single computer at any one time. This means that the software should be loaded on only
one hard drive at a time. If you wish to use this software on more than one computer, you must either erase the software from the
first hard drive when you move the software to a second hard drive, or else purchase two copies of the software. You may not
<None>under any circumstances have this program loaded onto the hard drives of two or more computers at the same time. You
also may not copy this software onto a hard drive and then use the disks on another computer. The software may be executed
from a common disk shared by multiple computers provided that one autherized copy of the software has been licensed for each
computer executing the software.

2) Copyright

This software is owned by MetaCreations and is protected by United States copyright laws and international treaty. By law, you,
the end user, may do the following:

a) make a copy of the software solely for backup or archival purposes; or
b) transfer the software to a single hard disk, provided you keep the original solely for backup or archival purposes.

United States copyright taws prohibits you from making any other copy of the software for any reason without our permission.
These federal copyright laws also prohibit you from copying the written materials accompanying the software without first
obtaining our permission

3) Restrictions

You may not rent, lend, lease, or assign this software. You may, however, transfer the software and the accompanying written
materials on a permanent basis. When you transfer the software on a permanent basis, you may not keep any copies, and you
must remove the software from your hard disk. Also, the person to whom you transfer the software must agree to the terms of this
License.

You may not alter, modify or adapt the software or accompanying materials. In addition, you may not translate, decompile,
disassemble or reverse engineer the software. You also may not create any derivative works based on this software. A derivative
work is defined as a transtation or other form in which the software may be recast, transformed or adapted.

4) Limited Warranty

MetaCreations Corporation warrants that this program will perform in substantial compliance with the published specifications
and documentation supplied in this package, provided it is used on the computer hardware and with the operating system for
which it was designed. This warranty is limited to a period of 90 days from the date of the original purchase.

MetaCreations Corporation warrants that the original disks and documentation are free from defects in material and
workmanship, assuming normal use, for a period of 80 days from the date of purchase.

5) Remedies
If you report a significant defect in performance of the software in writing, within 90 days of purchase, MetaCreations Corporation
will attempt to correct it or, at its option, authorize & refund of your license fee.

If a defect in the disk or documentation occurs during this period, you may return the fauity disk or documentation, along with a
dated proof of purchase, and MetaCreations Corporation will replace it free of charge.

6) No Other Warranties

Except as specifically provided above, MetaCreations Corporation makes no other warranty or representation, either express or
implied, with respect to this software, the disks or documentation, including their quality, merchantability, or fitness for a particular
purpose. In no event will MetaCreations Corporation be liable for direct, indirect, special, incidental, or consequential damages
arising out of the use or inability to use the software or documentation, even if MetaCreations Corporation has been advised of
the possibility of such damages.

The warranties and remedies set forth above are exclusive and in lieu of alt others, oral or written, express or implied.

MetaCreations Corporation is not responsible for any costs including, but not limited to, those incurred as a result of lost profits or
revenue, loss of time or use of the software, loss of data, the costs of recovering such software or data, the cost of substitute
software, claims by third parties, of other similar costs. In no case will MetaCreations Corporation’s liability exceed the amount of
the license fee.

The warranties provided give you specific legal rights. You may have other rights which vary from state to state. Some states do
not allow the exclusion of incidental or consequential damages, or the limitation of how long an implied warranty lasts, so some
of the above may not apply to you.

7) U.S. Government Restricted Rights

MetaCreations LogoMotion and documentation thereto are provided with RESTRICTED RIGHTS. Use, duplication or disclosure by
the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer
Software clause at 52.227-7013. The contractor/manufacturer of

LogoMotion and documentation thereto is MetaCreations Corporation, P.O. Box 66959, Scotts Valley, CA 95067-6959,
(408) 430-4000
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MetaGreations LogoMotion

Minimum System Requirements
Windows

Pentium computer running Windows 95 or Windows

NT 4.0
A minimum of 16MB RAM

A minimum of 30 MB hard disk space. You'll need
additional space to store any scenes you create

A 14-inch maonitor supporting 16-bit color
A CD-ROM drive

Macintosh

Power Macintosh or compatible modet running
System 7.6.1 or later

A minimum of 16 MB of free RAM

A minimum 30 MB hard disk space. You'll need
additional space to store any scenes you create

A 14-inch monitor supporting 16-bit color
A CD-ROM drive
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CHAPTER 1

WELCOME TO LOGOMOTION

Welcome to LogoMotion™, the simplest 3D program
for multimedia artists, business presenters, and Web
designers. LogoMotion is ideal for quickly creating
animated 3D graphics for multimedia or business
presentations, for Web sites, for trade shows—any
type of demonstration where you want to create an
impact with your logo using the power of 3D and
animation.

LogoMation's easy animation features let you create
great animations for any kind of demo or presentation,
whether it's on the Web, in the board room, or at a
company meeting. Your own creativity in combination
with LogoMotion’s Stagehands™ help you quickly
produce fully animated 3D worlds. Imagine your
company logo in shining 3D chrome, rising against a
backdrop of starlit sky as the camera flies up and
over your 10go. Using LogoMotion, you can create this
type of flying logo in much less time than it would take
using traditional, bulkier 3D modeling programs.

What’s New in LogoMotion

LogoMotion has new tools, features and
improvements from earlier versions. For those
upgrading, the following overview provides a head
start on locating, learning, and taking advantage of
these additions.

Here's what’s new in version 2.0:

¢ New shading mode. LogoMotion’s new Best
quality shading mode provides even better image
quality than in the past with the addition of a Phong
shading rendering engine. Using this shading mode,
you can produce broadcast-quality output.

* Shadow casting. Objects can cast shadows,
which you view using the new Best shading mode.

¢ Texture mapping. Apply images and movies to
any object in your 3D world. You can create woods,
marbles, and other surfaces, which you view using
the new Best shading mode.

¢ Drag and drop interface. Enhanced drag and
drop ability lets you quickly drag items such as
surfaces bevels, backdrops, cameras, lights, and
more from a control panel and drop them in your
scene. No more going from dialog to dialog to create
objects and edit your scenes. Plus, new sliders and
buttons graphically update your scene as you make
changes, giving you further fine-tuned contral over
your scenes.

*  New Navigation tools. New Hand and Magnifying
Glass tools help you move around in the view
windows. These tools function similarly to those found
in 2D applications.

* Extended Bevel Control. Using the Bevels Control

Panel, you can choose from new bevel types and
place them on your text or extruded objects.

* Custom StageHands. Save those cool cameras
and other objects you've created by making them into

your own personal StageHands. This lets YOu use
them time and time again and pass them around to
your friends.

Here's what's new in version 2.1:

*  QuickDraw 3D". Available on both Macintosh and
Windows platforms, QuickDraw 3D lets you
manipulate solid, texture-mapped objects in real time.
This lets you build 3D animations more easily than in
Wireframe mode and is a lot more fun.

*  Spline-form workshops. The new Extrude and
Lathe Workshops let you build very smooth, accurate
3D models. You can tweak logos and text to
perfection using bezier spline handles like those
found in vector-based applications such as Adobe
lustrator™ and Macromedia Freehand™.

About Your User Guide

This manual provides all the information you need to
get the most out of LogoMotion. It will help you learn
the application and serve as a reference as you
attermpt more sophisticated procedures and effects.

This user guide assumes you are already familiar with
basic Macintosh and Windows concepts—menus,
dialags, and mouse operations, such as clicking and
dragging. If you need more information on these
subjects, or on the Macintosh Finder or the Windows
Desktop, refer to the Macintosh User's Manual or the
Microsoft Windows User's Guide, respectively.

The best way to learn LogoMotion is to read the
chapters “LogoMotion Overview"” on page 3 and
"Basics" on page 17 then complete the lessons in
“Tutorial” on page 23. The tutorial leads you through
the process of creating and modifying objects,
creating animations, and using StageHands as
shortcuts to speeding up the process.

After you complete the tutorial, open a new file and
start building your own scene.

...-.——.——------.-..-......l



Conventions

The LogoMotion User Guide is for both Macintosh and
Windows. By convention, Macintosh commands
precede Windows commands in the text. For
example, Command/Clri+l, is equivalent to the
Macintosh Command-I and the Windows Ctri+l. For,
simplicity, the term folder refers to directories as well
as folders. The LogoMotion interface for Macintosh
and Windows platforms is identical, unless otherwise
specified. The convention to a menu follows the rule
of the menu name> menu item.

Modifier Keys

When a modifier key differs between the Macintosh
and Windows platform, the Macintosh modifier is
listed first followed by a slash and the Windows
modifier key. Option/Alt means Macintosh users press
the Option key and Windows users press Alt.

GETTING STARTED
Windows Installation

1. Insert your Digital Image Productivity Software Suite
Disk 2 into your GD-ROM Drive.

2. Using the Explorer, locate the LogoMotion Program
Files folder on the CD.

3. Find the setup.exe file and double-click it.

4. Follow the on-screen instructions to compiete the
installation.

To access StageHands:
1. Place your Digital Image Productivity Software Suite
Disk 2 in your CD-ROM drive.

2. Launch LogoMotion.

3. Choose Windows>StageHands to switch to
StageHands mode.

Macintosh Installation

1. Turn off any virus protection and compression
programs and close any other applications currently
open.

2. Insert the LogoMotion CD-ROM into your CD drive.

3. Double-click the Installer icon from the CD-ROM
and follow the instructions on screen.
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CHAPTER 2
OVERVIEW

Introduction
This chapter introduces some of the major features
and concepts of LogoMation.

With LogoMotion you can quickly create high-quality
animated 3D logos and text. Logos stored as EPS
files can be instantly converted into a 3D object in
LogoMotion. Objects in LogoMotion can undergo
rapid transformations using StageHands,
LogoMation's collection of pre-animated props,
cameras, lights, and backdrops.

LogoMotion is the ideal tool for easily and quickly
creating 3D animations without having to learn
complicated modeling and motion concepts
traditionally required by 3D animation programs.

Application Overview
The following sections describe the components that
make up LogoMotion’s user interface:

* The scene, where you create your 3D world.

* The view windows, where you view your scene
from various angles.

¢ The world coordinate system, which helps you
stay oriented in the 3D world.

* The Toolbox, which contains tools to create and
manipulate objects.

¢ The Extrude and Lathe Workshops, where you
create complex objects.

¢ The Control Panels, where you can set detailed
options for the scene and the objects within it.

* The Sequencer, which you use to create
animations.

What Is a Scene?

In LogoMotion, a "scene” is an independent and
unique three-dimensional world that can contain
various objects: text objects, lathed and extruded
objects, props, lights, backdrops, cameras, and more.
The objects in the scene can move over time, creating
an animation. A scene and all its objects appear in
the Camera View window

A new scene opens each time you launch
LogoMotion. LogoMotion lets you have more than one
scene open at a time, limited only by the resources
available on your computer.

Control Panet Control Panel Bin

Control Panel Menu Camera View Window

A new LogoMotion scene.




The LogoMotion View Windows

There are four interrelated view windows in

L ogoMotion:

e Camera View

s Top View

+  Front View

e Right View

The Camera View Window

Each scene has a Camera View window, which is the
main window you work with in LogoMotion. With the
Camera View, you can lcok at the 3D world contained
within it from any position and orientation. The view
inside the window is connected to a camera object
that exists in the 3D world. In Camera View, you don't
see the camera as a separate object.

<) Tamers

The Camera View window displays the scene as
seen through the lens of a camera.

When you move the camera object in the world (you
move the camera object itself from the standard
views), the Camera View updates accordingly. You
can have only one camera object in a scene at any
time.

You can resize the Camera View by dragging the
fower right corner of the window. Note that when you
resize the Camera View, the relative scale of the
objects in the scene stays the same. Making the
Camera View larger doesn't bring more of an object
into view, but simply makes the scene appear larger
on the screen.

Tip: Keeping the Camera View small heips
conserve memory.

Standard View Windows
In addition to the Camera View window, you can also
open three different standard view windows:

Each of the standard views offers a different
perspective of the 3D scene. These views are always
fixed to a plane. Looking through the three standard
views is like looking through the top, front, and right
sides of a fish tank; your 3D models represent the
items inside the tank.

Of course, the items look different depending on
which view you're looking at. For example, you may
be able to read the letters in a text object in Front
View, but you won't in Top View because you're only
seeing the top of the 3D letters.
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In addition, you can see the camera object itself in the
scene from any of the standard views.

Top View

Front View

Right View

The standard view windows.

Standard views never swivel or rotate, and thus
provide a helpful reference when navigating through
the scene.

You might want to keep one or more of the standard

views open at any time to help you arrange objects in '

the scene. Because their primary purpose is for
alignment, the standard views don't show objects in
perspective. Grid planes are provided in the standard
views to help you align objects more precisely.
Standard views can be resized in the same way as
the Camera View: by dragging the lower right corner
of the window.

The World Coordinate System

Because LogoMotion is a 3D program, its 3D world
contains three dimensions: width, depth, and height.
These dimensions correspond to three coordinate
axes of motion: X, Y, and Z.

*  Width is represented by X. Think of X as running
across your screen from left to right.

Depth is represented by Y. Think of Y as
stretching from the front surface of your monitor
to the back.

Height is represented by Z. Think of Z as
reaching from the top to the bottom of your -
screen.

The world coordinate system lets you specify any
object's position in the 3D world using X, Y, and Z
coordinates. While using the Front View window,
moving an object left and right moves it along the
world’s X axis. Moving it in an in-and-out motion (that
is, towards or away from you) moves it along the Y
axis. Moving it up and down moves it along the Z
axis.




As you might guess, the center of the 3D world is 0,
0, 0. The numerals represent coordinates (or
locations) along each of the axes. All the view
windows start out “looking” at the center of the world.
The coordinates of the objects in the 3D world are
relative to the center point of the world. {n the Front
View, for example, as you move an object along the X
axis, the X value increases or decreases.

Showing the Axes in the World

In each of the views, you can display an axis guide,
which represents the axes in relation to the view. You
use the axis guides to help you figure out the positive
direction along an axis.

An axis guide in a window.

By default, LogoMotion displays the axis guides on
startup. You can remove them if you like.

To remove axis guides:
Choose Edit> Preferences and deselect the Show
Axes in Views option in the Preferences dialog.
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Turn axis guides on or off with the Preferences dialog.

The Toolbox

The Toolbox contains tools that make it easy to work
with 3D objects in your scene. The Toolbox appears
on the far left side of the screen when you first launch
LogoMotion. It's free-floating, so you can drag it
anywhere on the screen. It stays visible above any
open view windows.

The Move Tools

One of the most commaen things you'il do in

LogoMotion is dragging objects around in the 3D

world. There are two Move tools located in the top

position of the Toolbox:

¢  The V-Plane tool, which you use to move an
object left, right, up, or down along an imaginary
vertical plane.

*  The H-Plane tool, which you use to move an
object left, right, in, or out along a horizontal plane.
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Both tools help you move an object through the scene
along one particular plane of motion. Together, these
two tools let you place an object anywhere in the
scene.

When moving an object away from you with the H-
Plane tool in the standard views (Top, Front, ar Right),
you might intuitively expect the object to get smaller.
However, the standard views display objects
orthographically, which means that there is no
perspective. No matter how far away an object is, it
always appears to be the same size in the standard
Views.

The Scale Tools

The Scale tools let you change the size of an object.
You can either keep the object’s proportions the same
(using the Uniform Scale tool), or skew the object's
proportions to create a different effect (using the
Squash and Stretch tool).

The Uniform Scale Tool

While working in LogoMotion, you might want
to change an object's size, making it larger or
smaller but not changing its basic shape. You can
change an object’s dimensions along all three axes at
once with the Uniform Scale tool.

This cube is smaller after being scaled down with the
Uniform Scale tool. Notice that the basic shape hasn't changed;

its proportions remain the same

=1 The Squash and Stretch Tool
£ As its name implies, the Squash and Stretch
tool compresses or lengthens an object
without keeping its original propartions. You use the
Squash and Stretch tool ta scale an object along only
one axis. Squashing and stretching are particularly
useful when creating certain animation sequences.
For example, a ball bouncing on a table looks more
realistic if it squashes slightly upon impact.
5 = v (5 W Camera

T
o

A cube is stretched with the Squash and Stretch tool
to form a new shape.




The Rotate Tools

Three Rotate tools let you rotate an object around its
center point in practically any direction.

w=x] The Rotate Towards/Away Tool
@ The Rotate Towards/Away tool rotates an
object toward or away from you in any view.

S Camers SaRERIGERTR

A cube before and after it’s rotated towards the viewer
with the Rotate Towards/Away tool.

The Rotate Left/Right Tool
The Rotate Left/Right tool rotates an object left
or right in any view

the Rotate Left/Right tool.

The Rotate Around Tool
The Rotate Around tool rotates an object
sideways in either direction in any view.

A cube before and after it's rotated sideways o the right
with the Rotate Around fool.

The Rotate tools, like the Move tools, work in relation
to what you see on the screen. For example, the
Rotate Left/Right tool always rotates an object left or
right relative to your eye, regardiess of the window
you are using it in.
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The Object Creation Tools

[S)
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The Object Creation tools are used to place objects
into the scene. They include the Text tool, the
Extrusion tool, and the Lathe tool.
The Text Tool
‘{ﬁ? The Text lool places extruded 3D text into the

scene.The fonts available for the text object
are the fonts you have installed on your computer

A text object created with the Text tool.

zzw=1  The Extrusion Tool
A 14 The Extrusion tocl places a default extruded
= object (a cube) into the scene. The object
shown in the following illustration began as a cube
and was edited in the Extrude Workshop.

An object created with the Extrusion tool.

The Lathe Tool

The Lathe tool places a default lathed object
(a sphere) into the scene. The object shown
in the following illustration began as a sphere and was
edited in the Lathe Workshop.

An object created with the Lathe tool

;] The Hand Tool
,é, ,’" The Hand too! is used for window navigation.
It lets you move your view intc the scene up,
down, left or right in any view window (Camera, Top,
Right, or Front). When you click within the window and
drag, the scene shifts to reflect the new position.
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The Magnifying Glass Tool

The Magnifying Glass tool lets you zoom in
and out of any of the view windows. Zooming
in and out does not change the position of the camera
in the scene in the same way the Hand tool does.
Dragging right with the Magnifying Glass tool zooms
in, making the objects appear bigger on your screen.
Dragging left with the tool zooms out, letting you see
maore of the objects in the scene.

ro'g

]

_ fal - _
A scene before and after it's zoomed in
with the Magnifying Giass tool.

Sticky Tools

LogoMotion contains a feature called “Sticky Tools,”
which lets you keep a tool selected in the Toolbox
after you use it. Enabling Sticky Tools is particularly
useful if you're adding or scaling many objects. You
can turn Sticky Tools on or off by choosing Edit>
Preferences and making your choice in the dialog that
appears. When Sticky Tools is on, you can specify
that it be active all the time or only when Shift-clicking
a tool.

The Extrude and L.athe Workshops

Two special environments in LogoMotion—the Extrude
and Lathe Workshops—Ilet you create complex
objects by editing objects that began as simple
cubes and spheres.

When you enter a Workshop, its two workshop
windows (the Object window and the Extrude or Lathe
window) fill the screen. You work with a cross section
of an object in the Extrude or Lathe window, modifying
its shape and points. You use the Object window to
preview the changes you're making.

Lathe Window Objec; window
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An object in the Lathe Workshop
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The Control Panel

LogoMotion's Control Panel is your
command center for creating 3D worlds and
animations. It's located below the main
menu bar and stretches across the top of
the screen.

The Control Panel has six different modes,
each serving a different purpose. The
modes are Object Info, Surfaces, Bevels,
Atmosphere, StageHands, and Rendering

Object Info mode lets you numerically manipulate
every object in your 3D scene. You can edit an
object’s name, uniform scale, surface, shadow-
casting ability, visibility, position, orientation, and
dimension.

You can always use the tools in the Toolbox to modify
objects. The Toolbox tools can be more intuitive but
can also be imprecise. Use Object Info mode when
precision is important. Enter values directly into the
boxes on the right side of the Control Panel.

When dragging objects, the values in the Object
Info Control Panel update automatically.

Surfaces Mode

Uae Parent Surface
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Surfaces mode lets you interactively apply new
surfaces to objects. Various surfaces are available in
the bin on the right side of the Control Panel. All you
have to do is drag a surface fram the bin onto an
object in the scene.

You can edit surface parameters while in Surfaces
mode. These parameters include the surface's color,
diffuse shading, highlight, metallicity, and
reflectiveness.

Also, you can assign any 2D PICT image or
QuickTime movie as a new surface in this mode. To
apply it, you “texture map” the image so that it wraps
around any 3D object in your scene.

Bevels Mode

8 e | CE—
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Bevels are curves or angles added to the edges of
objects. These edges help the object catch and
reflect light. In Bevels mode you can assign bevels to
any text or extruded object in the scene. You can add
a bevel to an object by dragging a bevel in the bin on
the right side of the Control Panel onto an object in
the scene. Bevels mode lets you set parameters to




individually control how dramatic or subtle a bevel is
for each abject.

Atmosphere Mode

o H
Atmoaphers Background Ambdrant Fog
Atmosphere mode lets you 'set a general mood for
your scene. For example, you can create a scene
where the objects look like they exist in murky fog.
The background color, ambient lighting, fog levels,
and environment mapping can be adjusted in this
mode.

Modeling and animating objects in a 3D computer
world is somewhat like working in a vacuum. There is
nothing in the scene’s surrounding space 1o be
reflected by your objects. With nothing to reflect, even
the shiniest sphere will look dull.

Environments can give your reflective objects
something to refiect. A metallic environment is
automatically loaded when the first object in a new
document is shaded. The effect is obvious when
viewing objects in Best mode; it may not be as
apparent in Fast mode.

StageHands Mode

StageHands let you create 3D animations without
having to create the individual components yourself.
StageHands include props, cameras, lights, and
backdrops. Each StageHands object is ready-to-go,
complete with animation (when appropriate). All you
have to do is drag the StageHands elements you want
from the bin on the right side of the Control Panel into
your scene.

There are four difterent types of StageHands available
in the StageHands Control Panel: props, cameras,
lights, and backdrops. The following sections briefly
describe each of them.

Props

Props are pre-animated obijects that you can place in
your scene. This makes it easy to start working in 3D
without having to create your own animated models.
Of course, you can madify a prop’s shape and
animation, but the basic work is already done for you.
You can add as many props as you want to your
scene.

An animated baseball player prop.
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Props with many parts often have an invisible
parent. This parent object lets you manipulate all
of the parts of the prop (moving it, scaling it, and
so on) at the same time.

Cameras

Think of the camera as your eye in the 3D world.
There are a number of pre-animated cameras to
choose from that offer several ways to view your
scene. These cameras are probably the simplest way
for you to create stunning flying logos. When you use
StageHands mode to add a camera, the existing
camera object in the scene is replaced and animation
information is updated in the Sequencer. There can
be only one camera in the scene.

@ Default Camera
' Drive Bomb Left

I@ Pan Around® !
10

Use ready-to-go camera moves to fly through a scene.

Lights

Lights illuminate your 3D scenes. StageHands offer
you several pre-animated lights to provide a variety of
illumination effects. While you can use as many lights
as you want, you should be aware that each light you
add increases rendering time. Consequently, it's a
good idea to limit the number of lights in a scene and
to delete any unnecessary lights.

A light added to the scene highiights the objects in it. o

Backdrops

Backdrops provide a background upon which you
can stage your 3D production. Backdrops are still
images, and on Macintosh computers, can be
QuickTime movies. They are part of the background
and remain unaffected by changes you make to other
elements in the scene. For example, you canaim the
camera in a different direction, but the backdrop will
not change. '




A backdrop added to the scene.

There are several StageHands backdrops, but you
can also use your own images as backdrops. Just
place them in the Backdrops folder on your hard
drive, and they'll appear in the bin on the right side of
the Stagehands Control Panel. You can then drag
them into your scene.

For Macintosh computers, you can specify a movie as
a backdrop. It plays behind your animated objects.
This is a great way to place flying 3D text over digital
video.

Category Pop-up

The Category pop-up in StageHands mode is where
you select a folder whose elements appear in the bin
at the far right of the Control Panel. To switch folders,
simply click and choose a different category. You can
then scroll through the bin to see the various choices.
Each StageHand has a real-time preview that appears
in the preview area when selected.

StageHands on CD-ROM

Included with the full version of LogoMation is a
supplemental CD-ROM that contains a StageHands
folder with hundreds of additional StageHands. In
order to access them, load the LogoMotion CD-ROM
in the CD drive before faunching LogoMotion.

Rendering Mode
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Rendering mode lets you determine the size and the
image quality of your camera window. These controls
let you set the shading quality, the anti-aliasing, and
whether the object casts shadows or not. Turning the
Visible button on forces LogoMotion to show all
invisible objects.

In Rendering mode, you can also choose from a
selection of default Camera View sizes or customize
the window to fit your exact needs.

If QuickDraw 3D is loaded on your system, clicking its
button enables you to drag shaded objects in real
time in the view windows. You don't have to wait as
long for the screen to redraw.

QuickDraw 3D gives you real-time manipulation of
shaded objects. It helps show you what final, high-
quality images will look like, but it isn’t suitable for
final movies.
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The Animation Sequencer

The Animation Sequencer is your headquarters for
creating animations. The Sequencer keeps track of
the objects in the scene and how they change over
time.

Time Tracker Punch InfOut World Time Marker
Markers
] = Unftitied === =]
IJ_:,]
0060100 (] loome oroo ozos o300 04 —
Object Name [0 oymnes
Camera e
Light L3 —
Text” .
-
CHAT i Dz

Object Name List Obiject Timeline

How objects appear in the Sequencer.

Each time you add a 30D object to the scene, it
appears in the Object Name list in the Sequencer.
(Backdrops and environments are not 3D objects, so
they do not appear in the Seguencer.) You can use
the Sequencer to move within your animation to
different points in time.

Eventmarks

Every object name in the Sequencer has at least one
small oval, called an eventmark, beside it. Each
eventmark containg information about an object, such
as size, color, orientation, and position in the 3D
world. If an object has multiple eventmarks connected
by blue or pink lines, it indicates that the object is
animated.
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Objects with blue or pink lines are animated.

Animation Preview

You can use the Sequencer to preview animations.
StageHand props, cameras, and lights are generally
pre-animated, so when you add them to your scene,
you'll probably want to preview the animation so you
can see how they move together.

When you preview an animation, you see how the
animated objects move in the scene. All the objects
appear in Bounding Box mode (as cubes) for faster
playback.

Keeping Track of Objects

The Object Name list appears on the left side of the
Seguencer. This list contains the names of every
object in your scene—even invisible ones. Objects
that have “child” objects linked to them have triangles
beside their names. Clicking a triangle either shows or




o
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hides the children of that object.

For example, if you add a prop composed of several
objects, a parent object appears in the Object Name
list. Click its triangle to see a list of all the objects
linked to it —its children.
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This graphic shows a parent object (Circling Stars)
and all its children beneath it.
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Chapter 3

BASICS

Overview

This chapter describes some of the basic operations
you'll need to know when creating 3D illustrations and
animations in LogoMoation.

Setting up LogoMotion

Launching LogoMotion

The first time you launch LogoMotion, you're
prompted to type in your name, organization, and
serial number. The serial number can be found in your
LogoMotion package.

To launch LogoMotion on a Macintosh computer:
*  Double-click the LogoMotion icon in the
LogoMotion folder.

To launch LogoMotion on a PC running Windows:

e From the Start menu, choose Program Files>
MetaCreations LogoMotion 2.1> LogoMotion
2.1.exe.

Increasing the Memory Partition for LogoMotion
On Macintosh computers, each application has an
associated memory partition size, which tells the
computer how much memory to allocate to the
application when it is launched. It's best to give
LogoMotion as much memory as possible so that it
can render high-quality animations as quickly as
possible.

To change the memory partition size on Macintosh
computers:

1. Quit LogoMotion if it is running.

2. Select the LogoMotion application icon in the
Finder.

3. Choose File> Get Info. The Info window appears
4. Set the Minimum Size field to the smallest amount
of RAM (in kilobytes) you want LogoMotion to use and
set the Preferred Size to the largest amount of RAM
you'd like LogoMotion to use.

16,000K is the lowest size you should specify for the
Minimum Size field.

5. Close the Info window.

Creating a New Scene

The 3D world document where you create your
animations is called a "scene.” Each scene is an
independent and unique 3D world where you can
build, animate, and save models.

When you launch LogoMotion, by default a new scene
automatically-opens. You can have more than one
scene open at a time.

To create a new scene:
¢ (Choose File> New.

A new, blank scene appears in the Camera View
window.
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A LogoMotion scene file.

Opening an Existing Scene
You can open files you've saved in LegoMation to
continue working on your scenes.

To open an existing scene:

1. Choose File> Open, then locate and select the
scene file you want to open.

2. Click Open.
The scene appears in the Camera View.

Switching Between Scenes
You can work on more than one scene at the same
time.

To switch between open scene files:

* Choose File> Scenes, then select the scene you
want to work on.

({10 Edit Options

Save xS
Save Rs...

Save image Rs...
Revert

import »
Enpart »

Make Movie.,, 8K

Page Setup...
print... xP
Buit %0

You can work on several scenes in the same session.

Saving a Scene
As with almost any software application, it's a good
idea to save your LogoMotion scenes periodically.

Saving a scene is different from making a movie of
your scene, although the operations look similar.
When you save your scenes, you're saving them to a
native LecgoMotion file format. This lets you open and
close the files as needed so you can continue
modifying and refining your scenes as much as you
want.

Making a mowvte is a one-shot operation. After you
make a movie, you can't edit the movie in LogoMogtion
unless you go back to the original scene file, make
your changes, then make a movie again.

You can also save a scene to an image file format
such as PICT or TIFF. Like movie files, once you save

a scene as an image, you can't modity the image file
in LogoMation. You need to return to the scene file to
make changes, then save it as an image file again.

To save a scene in LogoMotion:
1. Choose File> Save. The Save dialog appears.

2. Type a name for your scene, select a location for
it, then click Save/OK.

LogoMotion saves your scene.

Opening and Closing Standard Views

In addition to the Camera View, which is the main
window where you create scenes, you can open three
standard view windows: Top View, Front View, and
Right View.

The Camera View shows you the scene as if you were
looking through a camera lens. In contrast, the
standard views seem to stand further away from the
scene. They show you the scene from different
angtes, including where the camera object is in
relation to the other objects in the scene.

You can have one, all, or none of the standard views
open at a time.

To open a standard view:

* Choose Windows> Top View (or Front View or
Right View).

Open windows have a checkmark next to them in the

Windows menu.

To close a standard view:

» (Click the Close box in the upper left corner of the
view's window.

Or

* Deselect the view in the Windows menu.

Making a View the Active Window

Clicking anywhere on any view makes it the active

window. You can work in only one window at a time.

However, zall views update when an object in any one

window is manipulated.

' ma! :I Help
Hiide Floating Windows %XH

Object Info *®1
Surfaces ®2
Bevels %3
Atmasphere %4
v StageHands ®5
Rendering %6
~Taalbox ®2
Sequencer ®8
v Camera %9
front X
Right

Checkmarks in the Windows menu tell you which views are open.

Setting LogoMotion Preferences

There are various preferences you can set in
LogoMotion to suit your own personal working style.
The following sections describe the options you can
set.

You set options in the Preferences dialog.




To open the Preferences dialog:
s Choose Edit> Preferences.

The Preferences dialog appears.

= Preferences ===

] Startup Action Smart window placement
@ Default Scene [ Quick sbject drag
O "Open.. " Dislog (& Shov axes in views
(8 Sticky Tools (3 Return taariginal time
@ fvan (J dither colors
Shift-Click
o Cancel

Start-up Action
You can change the way LogoMotion appears when
you launch it:

* Default Scene starts LogoMotion with the Camera
View and Sequencer open.

* ‘Open... Dialog starts LogoMotion displaying the
Open dialog, which lets you open any scene files
you created.

To bypass both of these options, deselect the Startup
Action checkbox. LogoMotion launches displaying a
dimmed menu bar and Toolbox.

Sticky Tools

The Sticky Tools option lets you keep a tool selected
in the Toolbox after you use it. You can toggle Sticky
Tools on or off with the checkbox. When Sticky Tools is
on, you can have it active at all times (Always), or anly
when holding down the Shift key.

Quick Object Drag

If you have more than one view open—Camera View
and all the standard views for example—moving
objects in a window can seem sluggish because the
objects have to change in all the views. When Quick
Object Drag is turned on, only the window you're
working in shows the changes. The other open
windows won't reflect the changes until you're done
positioning the object. With Quick Object Drag turned
off, all the views update interactively.

Show Axes in Views

The Show Axes in Views option toggles the axis
guides on and off in the views. When you toggle the
axis guides on, they appear in every view window.
You can't display the guides in only cne view; when
turned on, they appear in every view.

Return to Original Time

When turned on, this option returns the World Time
Marker to its original position in the Sequencer after
rendering an animation or detailed preview. If this
option is deselected, the World Time Marker remains
on the last frame of your animation.

Dithering

Dithering is a method used to trick the eye into seeing
a greater range of colors than are actually present in
an image. For images represented by fewer than 24
bits of color per pixel, dithering can improve the
image quality dramatically. Turn this option on to
dither images.
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A 4-bit image with dithering.

Quitting LogoMotion
Before quitting LogoMotion, be sure to save any of
your scenes that are in progress.

To quit LogoMotion:
Choose File> Quit.
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Chapter 4
TUTQRIAL

Welcome

Welcome to the LogoMotion tutorial. The tutorial
introduces you to three of the main tasks in creating a
flying logo: creating an object, animating the object,
and rendering the scene.

The tutorial is divided into three sections. In the first
section, you'll use your name to create a three-
dimensional looking logo in chrome.

The second section introduces you to the camera,
which “flies” you through the scene, creating an
animation.

In the last section, you'll perform similar tasks that are
slightly more complex, but you'll use StageHands to
get the job done. StageHands are LogoMotion's
library of ready-to-use, pre-animated objects, lights
and cameras.

Before You Begin

Before you start working through the tutorial, be sure
to launch LogoMotion and to place the LogoMotion
CD-ROM in the CD-ROM drive so that you'll have
access 10 StageHands. For information about
launching LogoMotion, refer to “Launching
LogoMotion” on page 17.

See Your 3D Name on the Screen

In this section, you'll use the Text tool to create an
object in a scene. You'll then learn how to change the
object by modifying its shading and position and by
adding a backdrop. Finally, you'll learn how to save
your work in LogoMotion.

Lesson 1: Adding a Text Object to a Scene

Alogo is usually the name of a company displayed in
a distinctive font or manner. LogoMotion makes it easy
to add a name (or whatever combination of words you
want) to the scene by using the Text tool.

To add text to a scene:
1. Choose File> New to create a new scene.
A new, blank scene appears in the Camera View.

2. Select the Text tool from the Tootbox.

(Errs o e 3. Click the center of the

L ]| Camera View window.
r i The Text dialog appears.
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Type your name in the
text field and choose a font
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The lonts you can choose from

are the fonts you have instailed

on your computer.

5. Select the Straight Bevel button to add a beveled
edge to your name.

A bevel gives your objects an angled edge, which
creates the illusion of depth and helps catch and-

“reflect light.
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6. Click OK.

The dialog disappears and in a few moments your
name appears in Wireframe mode in the Camera
View.

The letters of your name are enclosed in red bounding boxes,
which means that your text object is selected.

Lesson 2: Changing Shading Mode

As you work in LogoMotion, you'll find you need to
change shading modes quite often, depending on the
task you're trying to accomplish. Shading modes let
you see the objects in your scene in different ways.
At this point, your name is shown in Wireframe mode.
Wireframe mode is like showing you a skeleton of an
object—all you see is the underlying structure of the
object.

In this next set of steps, you'll change the shading
mode of the object so that it appears solid.

To change the shading mode:

1. Click the left-most button in the Control Panel and
choose Rendering from the drop-down menu to
switch to Rendering mode.

it

The Control Panel changes to show you various rendering
options.

2. Click the Quality button in the Control Panel and
choose Fast for the shading option.

in a few moments, LogoMotion redraws your name on
the screen.




The letters of your name now appear sofid.
If you have QuickDraw 3D installed, click the
QuickDraw 3D button to use it. While working
within LogoMotion, you’ll find that objects shade
faster when QuickDraw 3D is activated.

Lesson 3: Changing the Object’'s Position

You can move objects in aimost any direction within a
scene. In the last lesson, your name appeared solid
after you changed the shading mode. Here, you'll
rotate the object a bit to create a greater illusion of
depth in the scene.

To rotate your name:
1. . Select the Left/Right tool from the Toolbox.

2. Inthe scene, grab your name by clicking the
object, then drag the pointer to the right slightly.

The text rotates slightly and gives a sense of depth to the scene
that wasn't there before. The first few letters of your name seem
closer to you and look bigger, the last letters look smaller
as if they are farther away.

Lesson 4: Adding a Backdrop

Backdrops can easily add special effects to your
scenes without requiring you to do a lot of work. The
next set of steps shows you how to showcase your
name by adding a backdrop to your current scene.
To add a backdrop:

1. Switch to StageHands mode by clicking the feft-
most button in the Control Panel and choosing
StageHands from the menu.

The Control Panel changes to show you StageHands
options.

TR |

Props Comores Lights Bakorops Catepory

The Stagetands Control Panel.

2. Select Backdrops on the StageHands Conir,
Panel.

A list of background images appears in the bin 1, y,,,
right.

MNatty Blue Carpet

Ocean Night Scene

The Backdrops bin in the StageHands Control FPanci

3. To preview an image, click it.
A preview appears in the Control Panel.

4. Select the Ocean Night Scene backdrop, thor,
drag it to the Camera View to add it to your scenc

The backdrop image appears behind your name.

If QuickDraw 3D is turned on in the Rendering
Control Panel, backdrop images do not appear.

Lesson 5: Changing Image Quality

So far in this tutorial, you've seen how objects appei
when they're rendered in Wireframe and Fast modu:;
You can increase the quality of the image by setting .
new shading option and changing to Rendering m i,
again.

Typically, you create objects and set up your scen: i,
the faster rendering modes (Bounding Box,
Wireframe, Fast) and then switch to higher quality
rendering (Better, Best) when you're ready to checi
how the scene will look when you're done.

The next set of steps shows you how to set optiont: |y
a high-quality final rendering of your name.

To render a high-guality image:
1. Switch to Rendering mode by clicking the lefl-

most button in the Control Pane! and choosing
Rendering from the menu.

] 2. Click the Anti-alias button to turn on
lﬁJ anti-aliasing.

Arti-alias  Anti-aliasing smooths jagged edges in th:
image. Turning this option on increases rendering
time, but is important for cbtaining the best quality 1oy

your final image.

. 3. Click the Quality button and choose
Best to change the shading mode.

Quality

MPAAARANNNANANANRANPANAAAANAARARARAARNNANAANANnRN

|



LogoMotion takes a few moments to render your
name smoothly in 3D chrome.

Changing the shading option to Best renders
the highest quality image.

Lesson 6: Saving your image

You can save your snazzy, chrome name as a
separate image file you can view in other
applications.

On Macintosh computers, you can save images as
PICT or TIFF files. On Windows computers, you can
save images as TIF, JPG, BMP, and other common file
formats.

To save your image:
1. Choose File> Save Image As.

A Save dialog appears.

2. Type a name for the file and specify the location
where you want to save it.

3. Click Save.
LogoMotion saves your image.

You can view your image in any application
capable of displaying common image file formats.
Usually, double-clicking the image launches an
appropriate viewing application.

Moving On

Congratulations! You've completed the first lesson of
the LogoMotion tutorial. At this point, you can quit
LogoMotion by chocsing File> Quit or proceed to the
next section. If you're ready to start the next section,
leave LogoMation running, but choose File> Close to
close the current scene.

Make a Flying Logo

This section introduces you to the basics of animation.
It shows you how to import an existing EPS logo to
use as an object in your scene. It also introduces you
to some different tools in the Toolbox and explains
how to set up the camera and “fly” it through the
scene to create motion.

Lesson 1: Importing an EPS Logo

EPS, which stands for Encapsulated PostScript, is a
standard file format available in many image editing
applications. If you have a logo image that was
created in another application and saved to EPS, you
can import it into LogoMotion and use it as an object
in your scene.
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To import an EPS file:

1. Launch LogoMotion if it's not already running and
create a new scene Dy choosing File> New,

2. Choose File> Import> EPS.

An Open dialcg appears.

3. Select the file called Sample EPS located on the
LogoMotion CD-ROM in the LogoMotion: Manual's
Tutorial Files: Manual Tutorial #2 folder.

4. Click Open.

The Sample EPS file appears in the scene as a 3D
extruded object.

An imported EPS file.

Lesson 2: Resizing an object

Earlier in the tutorial, you saw how to manipulate an
object by rotating it in the scene. This next lesson
introduces you to the Uniform Scale tool, which lets
you proportionally change the size of an object.

To change the size of an object:
1. Cilick the Uniform Scale tool in the Toolbox.

2. In the Camera View, click the logo object to
select it, and holding down the mouse button, drag
slightly to the right.

The logo enlarges to fit better in the Camera window.

Generally, dragging to the right with the Uniform
Scale tool enlarges an object; dragging to the left
shrinks it. The Uniform Scale tool enlarges or
shrinks an object along all three axes so that the
object always remains in proportion.

Lesson 3: Setting Up and Moving the Camera

So far in this section, you've imported an EPS file and
enlarged it. This next set of steps introduces you to
the tools and windows you need to position the
camera and make it move through time.

To set up the Camera:

1. Choose Window> Top to open a top view of the
Camera window.

A separate window called Top View appears on the
screen next to the Camera View.




The Top View window.

2 Find the camera object. (The camera object only
appears in the standard views; it does not appear in
the Camera View.)

Depending on the size of your screen and how your
desktop is set up, you might not see the camera
object in the Top View window, even though it's there.
If this is the case, use the Hand tool to move in the
Top View until you spot the camera cbject.

3. Drag the camera object using the V-Plane tool
until the camera object is to the right and in front of
the text object.

4. Choose Options> Point At> Object to point the
camera at the text object.

Top View

The camera object points at the text object in the Top View window.

Lesson 4: Flying the Camera Through Time
Changing the position of the camera over time creates
moticn—an animation. Now that you've set up the
camera, you're ready to move it from one point to
another. This lesson shows you how to fly the camera
through the scene so that the camera looks at the text
object from one angle and then ancther.

To move the camera:
1. Choose Windows> Seqguencer to open the
Animation Sequencer.

The Sequencer appears on the desktop beneath the
Camera View.

Time Tracker  Punch In/fOut Markers  Object Timeline
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The Sequencer.
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2. Choose Animate> Snapshot.

This marks a camera position at a certain point in the
animation. The World Time Marker moves forward a
haif second in time.

3. Return to the Top View and drag the camera
object across to the left of your logo

The timeline in the Sequencer shows a bar
representing a change to the camera object over
time.

4. Choose Options> Point At> Object to point the
camera object at the text object again.

This keeps the camera pointing at the text object,
even though the camera’s position has changed.

- T3]
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The camera still points at the text object.
5. Choose Animate> Preview to preview your
animation thus far.

The camera object moves in the Top View window to
show you the change in its position.

6. Save your work by choosing File> Save, naming
the scene, and clicking Save.

it's a good idea to save your work before rendering an
animation.

Lesson 5: Making a Movie

So far in this section you've imported an EPS file to
make a text object, enlarged it, set up the camera,
and moved the camera position. In this lesson, you'll
see how to turn your objects and animations into a
movie by rendering.

When you set LogoMotion to rendering, it generates
frames for your movie and saves them to disk. Later,
you can play the movie and watch the objects in the
SCene move across your screen.

To make a movie:
1. Choose File> Make Movie.

The Render Setup dialog appears.
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2. Set Quality to Best and Frames Per Second to 15,
then click Render.

The Save dialog appears.

3. Type a name for your mavie and choose a
location on your computer to store it.

4. Click Save.

The Render window and Status dialog appear, and
LogoMotion begins creating the frames of your flying
logo movie. This might take a few minutes to
complete.

5. When your movie is finished rendering, close the
Render window by choosing File> Exit.

6. Quit LogoMotion by choosing File> Quit when
your movie has finished rendering.

Lesson 6: Viewing Your Movie
Once your movie has finished rendering, you can play it.

To view your movie:
¢ From the desktop, double-click your movie’s icon
to launch a movie player and watch your movie.

Moving On

Congratulations! You've completed the second
section of the LogoMotion tuteorial. At this point, you
can proceed to the final section or quit LogoMotion by
choosing File> Quit. If you're ready to start the last
section, leave LogoMotion running and close the
scene by choosing File> Close.

Using StageHands

This section builds on the previous sections in the
tutorial by showing you how to create a more complex
animated movie. Adding complexity, however, is easy
when you use LogoMotion’s StageHands.

StageHands are a collection of built-in camera moves,
light positions, props, and backdrop images. Using
StageHands, you can create more complicated
animations without having to build every object from
scratch.

Lesson 1: Setting up the Scene

In this next lesson, you'll create a new scene, add a
text object to it, change the shading mode, and open
the Animation Sequencer.

To set up the scene:
1. Launch LogoMotion if it's not already running and
Create a new scene by choosing File> New.

2. Add atext object to the scene and type the
words “News Flash” in the text box.

3. Resize the text object if necessary to make it fit in
the window.

4. Change the shading mode from Wireframe to
Fast.

5. Open the Animation Sequencer by choosing
Windows> Sequencer.
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Lesson 2: Applying a Surface to a Text Object
When you change the shading mode to Fast, the text
object changes so that it appeared to be made out of
a solid material.

A surface is what makes the object appear solid, and
the default material surface is chrome. This next
lesson shows you how to change the surface of the
object.

To change an object’s surface:
1. Click the Control Panel and choose Surfaces from
the menu.

A list of available options appears in the bin to the
right of the Control Panel.

2. Scroll the list of available surfaces, clicking
different ones that interest you.

As you click different surfaces, the sphere in the
Preview area changes to show the effects of the
surface on an cbiject.

3. Once you've settled on a surface you like, drag
the name of the surface from the bin and drop it onto
the text object in the Camera View.

LogoMotion takes a few moments to redraw the object
with its new surface in the Camera View.

News Flash

Your text appears with the surface you chose.

Lesson 3: Adding a Prop to Your Scene

Props are part of the StageHands collection. They're
pre-animated 3D objects you can bring into your
scene. They save you time because you don't have to
build and animate objects from scratch.

In this next lesson, you'll add a prop to your scene.

To add a prop:

1. Click the Control Panel and choose
StageHands from the drop-down menu,
then click the Props button.

2. Scroll the list of available props in the bin on the
right, clicking different ones that interest you.

As you click different props, the prop in the Preview
area changes so you can see what it will look like in
the scene.

3. Once you've settled on a prop you like, drag the
prop icon from the bin and drop it into the Camera
View.
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The prop appears in your scene. Notice that the
prop’s name also appears in the Sequencer and has
animation information associated with it.




Lesson 4: Adding a Light to Your Scene

So far in this section, you created a text object,
assigned it a new surface, and added a prop to the
scene to create some interest. Now you're ready to
add some lighting to brighten the scene.

Lights create various effects in scenes and are used
to illuminate your flying logos. This next lesson shows
you how to add a light using StageHands.

To add a light:
Q 1. Click the Lights button in the
Lights  StageHands Gontro! Panel

2. Scroll the list of available fights in the bin on the
right.

As you click different lights, the light in the Preview
area changes so you can see what it will look like in
the scene.

3. Once you've settled on a light you like, drag it
from the bin to the Camera View window.

The light appears in the scene and in the Sequencer.

You can see lighting effects (shading for example)
in Camera View if Rendering mode is set to Fast,
Better or Best. You can’t see lighting effects when
Rendering mode is set to Bounding Box or
Wireframe.

Lesson 5: Deleting the Default Light

in 3D animation applications, the more lights or other
effects you add to your scene, the more time it takes
to render the scene. Plus you'll find that your objects
begin to look washed out when you add lots of lights,
so it's a good idea to delete extra lights.

This next lesson shows you how to delete the default
light. This light is unnecessary for the sceng you're
creating.

To delete a light (or any other 3D object in the scens):

1. Choose Options> Select Object> Light. (Light is
the name of the default light in this scene.)

2. Press the Delete key to delete the light object
from the scene.

LogoMotion redraws the scene using the light you
added in the previous task to highlight the scene.

Lesson 6: Adding a Camera to Your Scene

To give your scene a sense of action, you can bring in
an animated camera using one of the StageHands
cameras. This saves you from having to manipuiate
the camera object's position and orientation in order
to create an animation.

To add a camera:
} 1. Click the Cameras button in the
Cameras  OtageHands Controi Panel.

2. Scroli the list of available cameras in the bin on
the right.

3. Once you've settled on a camera you like, drag it
from the bin to the Camera View window.

The existing camera in the scene is replaced by the
one you chose, and the Sequencer updates to show
the new camera at the bottom of the list.
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The new camera appears in the Sequencer.

Lesson 7: Finishing the Scene

At this point in the section, you've set up a scene
that's just about ready to make intc a movie. There are
a few final tasks: adding a backdrop, saving your
work, and of course, making and viewing the movie.
To finish the scene:

1. Add a backdrop.

2. Save your work.

It's a good idea to save your work before rendering an
animation.

3. Choose File> Make Movie.

The Render Setup dialog appears.

4. Set Quality to Best and Frames Per Second to 15,
then click Render.

A standard Save dialog appears.

5. Name your movie, pick a file format (QuickTime
for Macintosh; AVI for Windows), and specify the
desktop as the location to save it to.

The Render window and Status dialog appear and
LogoMotion begins rendering your movie. You can
watch the animation frame by frame in the Render
window.

Because this scene is more complex than the
scenes in the previous sections, it may take longer
to render than you expect.

8.  When your animation is finished rendering,
choose File> Exit to return to the Camera View.

7. View the movie by double-clicking the movie icon
on your desktop.

A movie viewing application launches and dispiays
your movie.

Tutorial 3 Movie =

Your movie plays on your screen.
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On Macintosh computers, the Movie Player Utility
plays your movie. On Windows computers, Active
Movie plays your movie.

Wrapping Up

Congratulations on completing the LogoMotion
tutorial! Now that you've finished the lessons, you
might be asking yourself where to go from here? The
best way to learn LogoMotion is to experiment on your
own. The techniques outlined in this tutorial are only
the beginning. You can apply the skills you've learned
to any project you have in mind.

The remaining chapters in this User Guide explain in
detail the features and functions of LogoMotion, but
remember, you can return to this tutorial at any time to
brush up on fundamental LogoMgtion techniques.
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Chapter 5
CREATING OBJECTS FOR YOUR SCENE

Introduction

This chapter describes the tools you use to create
objects for your scene. It also explains the Extrude
and Lathe Workshops, areas you enter to modify the
basic shapes you create. The last part of the chapter
gives you information about other ways to create
objects, including using StageHands.

Types of Objects
There are three basic types of objects you can create
in LogoMotion:

* Text objects—Text objects are 3D objects made
up of text strings. LogoMotion automatically extrudes
your text string to give it a three-dimensional
appearance. You create text objects with the Text tool.
* FExtruded objects—Extruded objects are 3D
objects that have the same cross section all the way
through and are pulled out along a path. An industrial
I-beam is an example of an extruded object. You
create extruded objects with the Extrusion tool.

¢ Lathed objects—Lathed objects are 3D objects
that have a circular cross section. A wine goblet or a
water bottle are examples of lathed objects. You
create lathed objects with the Lathe tool.

Creating Basic Objects
This section explains how to create a basic object
using each of the object creation tools.

Text Objects
Use the Text tool to create basic text.

> !‘ To create a text object:

%l 1. Select the Text tool in the Toolbox.
2. Click within the Camera View.

The Text dialog appears.
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The Text dialog.
3. Type the text you want to use in the text box.
4. Select a font from the Font pop-up.

5. If you like, change the value in the Extrusion
Depth field value if you want a thinner or thicker text
object.

Extrusion Depth specifies how far the text will be
extruded along the Z axis (that it. how deep it will
appear).

8. If you want to bevel your text object, select a




bevel type. Bevels are the angles that extend from the
edges of your type characters.

7. Click OK.

You can also create text in the Extrude Workshop.
Extruded Objects

Use the Extrusion tool to create an extruded object.

The basic extruded object that LogoMotion
automatically creates is a cube.

To create an extruded object:
1. Select the Extrusion tool in the Toolbox.

2. Click within the Camera View.
A wireframe cube appears.

3. Before releasing the mouse button, drag to resize
the cube so that it's the size you want.

Lathed Objects

Use the Lathe tool to create a lathed object. The
basic lathed object that LogoMotion automatically
creates is a sphere.

To create a lathed object:
1. Select the Lathe tool in the Toolbox.
2. Click within the Camera View.

A wireframe sphere appears.
B === Comere SR 1H

3. Before releasing the mouse button, drag to resize
the sphere so that it's the size you want.

Editing Objects

You can edit basic objects in LogoMotion to create
sophisticated 3D modeled objects. This section
describes how to edit text objects you've created. It
alsc explains how to use the Lathe and Extrude
Workshops, which are special environments where
you can make complex refinements to any lathed or
extruded objects.

Editing Text Objects

After you've created a text object, you may decide
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you want to change it slightly. For example, perhaps
you misspelled a word, or maybe you specified a
concave bevel when you really wanted a convex
bevel. It's easy to make these kinds of changes to text
objects.

To edit a text object:
1. Using the H-plane or V-plane tool, double-click
the text object you want to change.

The Text dialog appears.

2. Make the changes you want, then click the OK
button.

The object updates in the scene with the changes you
specified.

Break Text Into Characters

There might be times when you want to edit the letters
of a text string as individual extruded objects.
LogoMotion lets you break a text string into
characters. When you do this, the first letter is
designated as a parent object; the remaining letters
are linked as child objects. For more information on
parent-child linking (also known as hierarchical
modeling), see “Using Hierarchical Models” on page
57.

To break a text string into characters:
* Select the text object and choose Options> Break
Into Characters.

Breaking text objects into characters is an action that
cannot be undone. It also applies to all points in time.
Make sure you use it with caution.

Editing Lathed and Extruded Objects

Lathed and extruded objects are edited in special
areas of the application called the Extrude and Lathe
Workshops. Using the Workshops, it's easy to create a
wide variety of complex 3D objects that begin with
simple sphere and cube objects.

The Extrude and Lathe Workshops are very similar.
Most of the tools and functions work the same in both
workshops, but some of the tools are unavailable in
the Lathe Workshop.

The next several sections give you an overview of the
Workshops and provide details on the Workshops’
tools. Differences between the Extrude and Lathe
Workshops are also explained.

Workshop Overview

Two large windows appear when you enter the
Workshop. One of the windows is the Object window,
which shows a preview of your 3D object. The other
window is either the Lathe or Extrude window,
depending on which kind of object you're editing.
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The Extrude window on the right and the Lathe window on the left.
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To enter the Workshop:
1. Using the V-Plane tool, double-click a lathed or
extruded object (a sphere or cube).

Or

Select a lathed or extruded object, then choose
Options> Edit Object. .

Or

With a lathed or extruded object selected, press
Command/Ctrl-E.

2. Click OK if you see a message that asks “Convert
the primitive into an editable spline object?”

Cubes and spheres are considered primitive
objects and are stored in an optimized format.
When you change them into spline-based objects,
they take slightly longer to render.

When you're through editing an object, you can leave
the Workshop.

To exit the Workshop:
s Choose File> Exit Workshop.

LogoMation returns you to your scene.
The Object Window
The Object window provides a 3D view of the object.

This view isn't used to build objects, but simply shows
a preview of your work in progress.
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The Object window shows a 30 view of your object.

You can use three tools from the Tooibox in the Object
window:

s The Rotate too!, which rotates the preview so it
can be viewed at any angle

¢ The Magnifying Glass tool, which zooms in or out
of the Object window

* The Hand tool, which repositions the preview in
the window.

These tools are described in more detalil later in the
chapter.

The Render Menu

In the top left corner of the Object window is the
Render menu. The Render menu lets you choose the
way you want the preview in the Object window to
render.
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Low Detarl
Meg Detail
High Detail

The Render menu in the Object window.

¢ Shaded uses QuickDraw 3D to show a solid,
shaded object. If QuickDraw is not active,
LogoMotion shows a gray shaded object in the
Object window.

*« [ow Detail, Medium Detalil, or High Detail
determines the quality of the preview. High Detall
is useful for viewing detailed objects.

¢ Auto Spin continuously spins the preview, which
is useful if you want to see the object from all
sides. First, choose Auto Spin, then rotate the
preview with the Rotate tool.

The Extrude Window

If you've brought an extruded object (a cube) into the
Workshop, the Extrude window appears across the
top of the screen above the Object window.

=L L

orcem

% | | . O, ST s
b | 4

058 AT T T

Cross section cutline

The Extrude window in the Extrude Workshop.

The Cross Section Outline

The outline in the Extrude window is called a cross
section. LogoMotion extrudes the outline through
space to create a 3D object. A default cube outline
automatically appears in the Extrude window when
you first enter the Workshop. You modify the outline
using the tools from the Tootbox. The next section
describes the tools in the Toolbox.

""" Bl The Toolbox

The Workshop Toalbox contains tools you can
use to draw outlines, which in turn creates 3D
objects. These tools will probably seem familiar
to you if you've used a 2D drawing application
such as Adobe lllustrator.

The Toolbox for the Lathe window
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Some tools are available only for certain windows. For
example, only three of the tools in the Toolbox can be
used in the Object window. The rest of the tools are
unavailable and appear dimmed. If a tool appears
dim, it means it's not appropriate to use it in the active
window.

The Arrow Tool
k The Arrow tool is used to select, move, and
edit points in the Extrude window. Points
define the shape of an object’s cross section. Multiple
points are connected by lines in a "connect-the-dots”
fashion, creating an outline.

There are a few ways to select points with the Arrow
tool:

e (lick a point on the object outline.

¢ Drag a marquee around the points you want to
select in the Extrude or Lathe window.

 Hold down the Shift key and click multiple points.
To deselect a point, hold down the Shift key and
click the peint again.

e Choose Edit> Select All to select all points at
once.

To move points, select them and drag them to a new
location. To move an entire outline, click a spot on the
outline that doesn’t contain a point and drag it to a
new location.

Editing Points with the Arrow Tool

You can also use the Arrow tool 10 edit points. There
are four types of points in the Workshop: plain, corner,
curve and smooth.

Plain points create sharp corners and straight lines.

0

A plain point.
Corner points have bezier spline handles. These
handles control the shape of the lines extending from
the point. Spline handles on corner points can be
manipulated independently of one another.

—

A corner point.
Curve points have spline handles of different lengths
but which always remain parallel. This prevents sharp
COrners or seams On curve points.

1

A curve point.
Srmooth paints have pline handies that are both
parallel and of the same length. Smooth points ensure
the smoothest, roundest curves in an outline.

‘TW T
A smooth point.
To change a point from one kind to another:
1. Select the point.
2. Choose Object> Type of Point.
You can change the shape of a outline by dragging

the spline handles on a point.

If a spline handle is moved so close to its parent point
that the handle disappears, simply click the parent
point and drag the handle away from it.

Tip: Holding down the Shift key while dragging a
spline handle constrains a point’s rotation to 45
degree increments,

Joining Points

Sometimes you might find it useful to join two points
that are not connected.

To join two points:

* Select two end points of a curve and chocse

The top graptic shows points before being joined. the bottom,
graphic shows points after being joined.
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Splitting Points
Other times you might want to split two adjacent,
connected points.

To split connected points:

*  Select the points and choose Object> Spilit
Points.

) The Rotate Tool
G The Rotate tool rotates selected points
To rotate points:

around a center of rotation.
1. Select the point(s) you want to rotate.
2. Click the Rotate tool.

A small cross-hair appears in the Extrude or Lathe
window.

3. Click a spot in the window around which you
want the selected points to rotate.

The cross-hair moves to that spot.
4. Drag the cross-hair to rotate the selected points.

In the Object window, the Rotate tool simply spins
the object preview.

é—lﬂ The Scale Tool

The Scale tool scales selected points

towards and away from a chosen location.
The scale tool works in the same fashion as the
Rotate tool.

To scale points:
1. Select the point(s) you want to scale.

2. Click the Scale tool.

A cross-hair appears in the Extrude or Lathe window
at the place from which your selected points will
scale.

3. Click a spot in the window that you want the
selected points to scale to.

The cross-hair moves to that spot.
4. Drag the cross-hair to scale the points.
Al?" The Flip Tool

s

The Flip tool lets you flip selected points over
This tool functions like the Rotate and Scale tools.

an arbitrary line and rotate them afterwards.

To flip points:
1. Select the points you want to flip.

2. Choose the Flip tool.
A cross-hair appears in the Extrude or Lathe window.

3. Click a spot in the window around which the
paints will flip.
4. Click and drag the pointer.

A line appears between the mouse and the cross-hair,
over which the selected points flip. f you continue to
drag the pointer, the points rotate.
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The Pen and Pencil Tools
The Pen and Pencil tools are used to
draw new outlines.

Both of these tools occupy the same
space on the Toolbox. To switch between the two,
click the icon on the Toolbox and pick ong from the

pop-up.
Q You can create new outlines with the Pen
tool. Click the Pen tool several times in the
Extrude or Lathe window to create a chain of points.
Clicking and dragging lets you drag the spline handle
of the newest point. This can help you easily create
smooth, curved shapes.

The Pen Tooi
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1) Click with the Pen tool to create an anchor point.
2) Click again to add a straight line.
3) Click and drag to create a smooth curve.

The Pencil Tool

ﬁ You can draw freehand outlines with the
pencil tool. Simply drag the pointer in the

Extrude or Lathe window as if it were a pencil.

LogoMotion creates a series of spline points to

smoothly fill in the path you draw.
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The Pencil tool draws freehand curves.

Adding and Removing Points

You can add new points into an existing outline or
remove points from an outline with the Pen or Pencil
tool.

To add points to an existing outline:
1. Select the Pen or Pencil tool and place it on the
path at the spot where you want to add a point.

2. Hold down the Option/Alt key.
A small + (plus sign) appears beside the pointer.

3. Click to add a point to the path at the location of
the pointer.

To remove points:
1. Select the Pen or Pencil tool and place it directiy
on top of the point you want to remove.

2. Hold down the Option/Alt key.
A small - (minus sign) appears beside the pointer.
3. Click to remove the point.

The Razor Tool

The Razor tool splits outlines in the same way
that scissors cut paper.
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The lirst graphic shows an outline before using the Razor tool,
the second shows the outline after it's been cut.
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The Polygon Tools
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The four polygon tools create closed outlings. They
occupy the same space on the Toolbox. To switch
between the tools, click the icon on the Toolbox and
pick one from the. pop-up.

The four types of polygons you can create are
rectangles, ellipses, rounded rectangles, and regular
polygons (such as hexagons).

To create a polygon:
1. Select the polygon tool you want to use.

2. Click in the Extrude or Lathe window and drag
the pointer until the polygon is the size you want.

Tip: Holding down the Shift key while using one of
the Polygon tools constrains the polygon to equal
proportions. This creates perfect circles, squares,
and so on.

To change the number of sides of a regular polygon:
1. Doubte-click the Polygon tool.
The Shape Preferences dialog appears.

2. Set the number of sides you want for the polygon
in the Poly Sides field.

3. Click OK.

The next time you use the tool, it draws a polygon with
the number of sides you specified.
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Change how the Polygon tools work in the Shape FPreferences dialog.

=] The TextTool

f‘%ﬂi’; The Text tool allows you to create text
outlines. These are no different from other

outlines created in the Extrude Workshop, so they can

be edited with the Toolbox toals.

oty sudes [ k]

Usually, the quickest way to create text in a scene is
to use the Text tool from the main Toolbox and place
text in the Camera View. The advantage to using the
Text tool in the Workshop and manipulating it in the
Extrude window is that you can create unusual effects
by manipulating the individual points in the text
outlines.

The Text tool is not available in the Lathe Workshop.

To create text in the Extrude window:
1. Click the Text tool, then click in the Extrude
window.

The Text dialog appears.
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The Text dialog.

2. Choose the font, text, and spacing you want, then
click OK to add the text to the Extrude window.

The Magnifying Glass Tool
The Magnifying Glass tool lets you change
the view by zooming in or out of a window.

To zoom in on a workshop window:
1. Click the Magnifying Glass tool.

2. Drag a marguee around the area you want to
zoom.

To zoom out of a warkshop window:
1. Click the Magnifying Glass toal.

2. Hold down the Ogption/Alt key and click in the
window.

Zr The Hand Tool

*}‘. The Hand tool lets you reposition your view of
e the contents in a window. This is useful when
an outline or object preview is not centered
in a window; the Hand tool lets you paosition it where
you like.

SN

To reposition your view:

* (Click the Hand tool, then drag in the Extrude or
Lathe window to reposition the contents of the
window.

The Lathe Window
if you double-click a lathed object (such as a sphere)
in the Camera View window, you enter the Lathe
Workshop. The Lathe window in the Workshop looks
similar to the Extrude window, but the Lathe window
sits side-by-side of the Object window, rather than on
top of it as in the Extrude Workshop.

PG NPT ISP YOV, INEYUSC VOIS AP

The Lathe window

While the Lathe and Extrude windows look very
similar, the outline in the Lathe window functions in a
different manner. The outline is spun around a vertical
axis to create a 3D object.
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When spun around a central axis, this outline
creates a vase-shaped object.

The best way to build a lathed object is to work on
one side of the vertical axis in the Lathe window (“0”
on the ruler at the top of the window). Any outline you
create is mirrored on the other side of the axis. There
can only be one outline in the Lathe window; the
mirror outline is shown an the other side of the vertical
axis.

Using Tools in the Lathe Workshop

The Lathe window's Toolbox looks identical to the
Toolbox in the Extrude window, but not all tools are
available for use. The unavailable tools appear dim on
the Toolbox. The tools that are unavailable in the
Lathe Workshop are

¢ The Uniform Scale tool
* The Rotate tool

» The Razor tool

e The Text tool

The Lathe Workshop Toolbox

The remainder of the tools function as they do in the
Extrude window, but because the outline must be a
single “string” of points, you can't have muitiple,
separate outlines in the Lathe window.

Adding Bevels in the Extrude Workshop
You can add bevels to extruded objects in the
Extrude Workshop.

To add a bevel to an extruded object:
1. Choose Object> Bevel.

The Bevel dialog appears, from which you can apply
and customize a bevel of your choice.
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The Beve! dialog in the Extrude Workshop.




2. Choose the kind and height of a bevel you want,
then click OK.

LogoMotion applies the bevel to your object in the
Workshop. The object remains beveled when you exit
the Workshop and return to the scene.

Rulers, Grids and Guides .
Rulers are visible across the top and left side of the
Extrude and Lathe windows. Rulers can be very
useful when precisely positioning or aligning points.
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Rulers and grids appear by default.

Grids

Grids also help you position points in the windows. By
default, each grid mark represents one quarter of an
inch, but you can change this setting by choosing
Edit> Rulers. You can also change other ruler settings
such as magnification by choosing Edit> Preferences.

To make points snap to grid points:
s  From the Extrude or Lathe window title bar,
choose Options> Snap to Grid.

Guides

Guides can be very handy when precise
measurements are required. You can add vertical and
horizontal guides to the Extrude and Lathe windows
by clicking a ruler and dragging a guide into the
window. To remove a guide, simply drag it back onto
the ruler.
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Drag guides from the rulers to help you position points.
To make points snap tc guides:
* From the Extrude or Lathe window title bar,
choose Options> Snap to Guides.
Locking guides makes them unmovable, preventing
them from interfering with point manipulation.
To lock guides

¢ From the Extrude or Lathe window title bar,
choose Options> Lock Guides.
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Creating Other Objects in LogoMotion
There are a few other ways to create objects in
LogoMation:

* You can cut, copy, and paste objects from other
scenes

*  You can import 2D EPS files

* You can import models created in other
applications

* You can add pre-made StageHands to your
scene

Cutting, Copying and Pasting Between Scenes

You can cut, copy and paste objects, object
hierarchies, and object animation information between
scenes. This is a quick way to add objects into your
scene. It also allows you to build up libraries of
objects in different files for easy access.

For instance, it's probably more convenient to create
an object you want to use over and over (such as a
logo) by itself in its own file, and then copy and paste
that object into a complex, animated, flying-logo
scene later.

Note, however, cutting, copying, and pasting must
take place during the same session. You cannot copy
an object, quit LogoMotion, re-launch it, and paste in
your objects.

When you cut or copy an object, LogoMation also
copies the surfaces and animation information for
each object. When you later paste the object, you're
also pasting the surfaces and animation associated
with it.

Importing EPS Files

3D objects can be built from 2D EPS files created with
applications such as Adobe lllustrator™, Macromedia
Freehand™ and CorelDRAW™.

You can import an EPS file while working in the
Camera View or while in the Extrude or Lathe
Workshops. If you import an EPS file while in Camera
View, you have the choice of extruding or lathing the
object. If you import an EPS file while in either the
Extrude or Lathe Workshops, it's extruded or lathed
automatically.

To import an EPS file:
1. Choose File> Import EPS.

An Open dialog appears.
2. Choose the EPS file you want to import

Extruding an EPS file means that the outline stored in
the EPS file will be pulled through 3D space 1o create
an object like a 3D logo or text. Lathing an EPS file
means that the outline will be spun around a central
axis, creating glasses, cones, spheres, and similar
shapes.

If an EPS file is imported directly in the Extrude or
Lathe workshop, it will be extruded or lathed,
depending upon which workshop is open when you
import. It's more common to extrude EPS outlines;
there are a few things to consider when lathing them:




e Because lathed objects are built from a single
“open” outline, your EPS file must contain only
one chain of points.

e The outline contained in the EPS file will be used
as the left edge of the object, which is then spun
to create the salid, 3D object.

Sometimes LogoMotion is unable to import an
EPS file because the file has no valid path
outlines. Raster images (such as photos and
scans) and text generally fall into this category. If
this is the case, you need to convert whatever is
stored in the file into path outlines. To do this, use
an application such as Adobe lliustrator, Adobe
PhotoShop, or CorelDRAW.

Importing Models

LogoMotion can impart 3DMF files, and most DXF
files. imported objects can be used the same way
objects created in LogoMotion are used. The only
restriction is that imported 3D objects cannot be
edited in the Workshops.

To import objects in either format:
1. Choose File> Import> Objects.

The Import Object dialog appears.

2. Select either 3DMF or DXF formats in the pop-up,
select the file you want to import, then click Open.

DXF import

Although the Import Object dialog shows all existing
DXF files, only those that contain 3D Polyline
information can be imported. Standards for the DXF
file structure are very general and each application
that outputs DXF files does so slightly differently.
Approach the use of a DXF file with care because the
results may be unpredictable.

The LogoMotion DXF import filter supports most
commands in DXF files, except for the 3D Polyface
Mesh command. Most DXF files do not use this
command.

When you import a DXF file, you have the option of
making the model render as a smooth object. After
you choose the file you want to import, a dialog
appears, presenting you with these choices for
interpreting the model:

* Always Smooth. LogoMotion forces all the faces
of the object to appear as smooth as possible.

* Never Smooth. LogoMotion forces the object to
be as faceted as possible.

*  Smoothing Angle. You can specify the angle
under which the edges of the model are
smoothed. Edges with angles sharper than the
smoothing angle remain unsmoothed and sharp.

* Scale and Center. Regardless of the imported
object’s natural size and position, Scale and
Center causes it to appear in the center of the
scene at a manageable size.

* One Object Per Layer. This option causes the file
to be stored in an internal format that performs
efficiently. If you have difficulty importing large

DXF files, be sure this option is checked.

¢ Link Objects. If a DXF file contains many
individual objects, Link Objects brings them into
LogoMotion as a hierarchy so they can be moved
and animated more easily as a group.

e Use Color Info. If this box is checked, DXF
objects are imported with colors if color
information was saved in the DXF file to begin
with.

3DMF Import

3DMF files are very similar to DXF files, but the file
format is more standardized than the DXF file format.
3DMF files are most common on Macintosh
computers, but can be used under Windows 35 or
Windows NT 4 if the QuickDraw 3D DLL files are
present on the computer.

You import 3DMF files the same way you import DXF
files. The import options are identical between except
for these itemns:

¢ One Object Per Layer is not an available option.
e Use Color Info is not an available option.

* Force Backfaces is an option appropriate for
3DMF files only. Colors on 3DMF objects are
automatically used in LogoMotion. The Force
Backfaces option forces LogoMotion to draw both
sides of the object—the side facing the camera
and the hidden side. (Normally, LogoMotion
shades only the visible side of objects). If a 3DMF
object seems to have pieces missing, re-import
the object and make sure Force Backfaces is
checked.

Creating Object with StageHands

StageHands let you add premade objects to your
scene. With LogoMotion, you're not limited to using
the StageHands that come with the pragram. You can
easily create your own props, cameras, and lights.

To create your own StageHands:

1. Create an object using the tools and information
provided earlier in the chapter. ' "

2. Choose File> Export StageHand.
The Export StageHand dialog appears.
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3. Select the type of StageHand that you want to
create: prop, camera, or light.

4. Choose the gbject in the scene you want to
export.

5. Enter details about the object, such as your




name, address, e-mail, and cther comments.

6. Click Export.

On Macintosh computers, a QuickTime preview is
automatically generated for your new StageHand. On
windows computers, an AVl preview is created.

Once you have your new StageHand, you can use it
in different projects or post it online to share with
others.

You can create your own custom folders in which to
store your new StageHands. Just create new folders
inside the Props, Cameras, or Lights folder on your
hard drive. This way, the folder name appears when
you press the Category pop-up in the StageHands
Control Panel. This helps you organize your
StageHands for future use.

Viewing StageHand Information

If you double-click a StageHand in the bin in the
StageHands Control Panel, the StageHands
Information dialog appears. !f the StageHand is a
custom-made object, you'll find information such as
the name of the person who created the StageHand,
his or her e-mail address, and additional comments. If
the StageHand is one that came with your LogoMotion
package, the dialog displays only the StageHand
name. Click the Add button to place the StageHand
into your scene.
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The StageHand Info dialog.
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Chapter 6

ARRANGING OBJECTS IN YOUR SCENE

There are various ways 1o arrange the objects in your
scene. You can guickly use the tools in the Toolbox, or
you can precisely place objects by entering and
changing values in a Control Panel. This chapter
explains the various ways you can adjust and position
the objects in your scene.

Working Directly in Your Scene
The simplest way of arranging objects is to use the
tools in the Toolbox.

Moving Objects

Use the V-Plane or H-Plane tool to move an object left,
right, in, out, up, or down in a scene. For additional
information about the V-Plane and H-Plane tools, refer
to “The Move Tools” on page €.

To move an object:

1. Select an object in the scene.

2. Click either the V-Plane or H-Plane tool.
3. Drag the object to the location you want.

Tip: If you have lots of objects in a scene, the
objects can start to get in the way of other objects,
making it difficult to select or drag an object that
is obscured. If this happens, hold down
Command/Ctrl and click the object you want to
select. A pop-up menu containing the names of all
objects beneath the pointer appears, from which
you can choose the object you want.

Tip: If you hold down the Option/Alt key while
moving the object with the H-plane or V-plane tool,
it is duplicated and repositioned. This is the
quickest way to clone objects.

Constraining the Move Tools

As you'’re creating your scene, you may want to
position objects accurately. One way to do this is to
restrict an object’'s movement to a single direction
when moving it. When you click an object, its red
bounding box appears to show you that it is selected.
If you hold down the Shift key while dragging the
pointer over one of the sides of the bounding box, the
object is constrained to move along only one axis.

Scaling Objects

Use the Uniform Scale tool or the Squash and Stretch
tool to change the size of an object in the scene. The
Uniform Scale tool changes the overall size of the
object without changing its proportions. The Squash
and Stretch tool compresses or lengthens an ebject in
the direction you specify.

To uniformly scale an object:
1. Select an object in the scene.

2. Click the Uniform Scale tool.

3. Drag the object’s bounding box so that it grows
larger or smaller, whichever you prefer.

The object expands or contracts in all directions at
once.
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To squash or stretch an object:
1. Select an object in the scene.

2. Click the Squash and Stretch tool.

3. Drag the pointer over any face of the object’s
bounding box.

The object squashes or stretches in that direction.
Rotating Objects

Use one of the rotate tools to rotate an object in any
direction. You can rotate an object towards or away
from you, left or right, or around.

To rotate an object:
1. Select an cbject.

2. Click one of the rotate tools.

3. Drag the object in the direction you want it to
rotate.

Editing Objects in Object Info Mode

You can make changes such as visibility, shadow-
casting, position, orientation and scale to objects in
Object Info mode.

Visibility

There will be times when you want individual objects
to be invisible. Invisibility can be especially useful with
lights so that they won't appear when rendering your
final scene. When you turn the Visible button off, the
object is invisible throughout world time.

You can make an object seem to disappear during an
animation by double-clicking an eventmark in the
Sequencer and clicking End Animation in the dialog
that appears. For more information about end
animation, refer to “Ending Animation” on page 86.

Shadows

Objects have the ability to cast shadows on other
objects. This ability, on by default, can be turned off
or on by clicking the Shadows button in Object Info
mode.

Shadow casting cannot be animated. it is either on or
off for the entire sequence. Objects that cast shadows
take a bit longer to render than objects that do not
cast shadows, but shadows can add a dramatic
sense of depth to scenes with overlapping objects.

Shadows appear only when shading is set to Best
mode. Be sure that lights in the scene are set to
cast shadows, and that shadows are turned on in
the Rendering Control Panel before making your
final movie.

Editing Object Values

When you select an object in a scene, values
representing that object’s exact position, orientation,
and dimension appear in the Object Info Control
Panel for the current point in time. Values are given in
world coordinates that are relative to the center of the
world (0,0,0), uniess the object is part of a hierarchy.
(If it is part of a hierarchy, vatues are relative to the
object’s parent.)
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To the left of each value box is a lock. Each value can
be frozen by clicking its lock. By locking these values,
you can restrict an object’s ability to move or rotate, or
restrict its scale. If you lock all nine locks, you freeze
the object entirely. If you unlock all nine locks, you
can freely move, rotate and scale the object.

Objects can be manipulated with the Object Info
Control Panel by simply changing values and clicking
the Apply button.

Setting an Object's Position

The Object Info Panel is often used to position
objects.
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The Object info Panel.

To position an object at the center of the world:

1. Select an object.

2. Select the text in the X Position box in the Object
Info Control Parel.
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3. Type 0 (zero), then press the Tab key to move to
the Y Position box.

4. Type 0O (zero) for the Y position, then press the
Tab key to move to the Z Position box.

5. Type 0 (zero) and click the Apply button.

LogoMotion redraws the object at the exact center of
the world.

Follow the above steps to position objects elsewhere
in the world, substituting new values for the 0 values
you entered.

Setting an Object’s Orientation

The orientation (rotation) of an object can be adjusted
in the same manner as position—all you have to do is
adjust the values and click the Apply button. Using
the Object Info Control Panel is a good way to
precisely rotate an object. For example, you could
rotate an object exactly 90 degrees.

When you rotate an object with the rotate tools in the
Toolbox, the rotation is relative to the view you're
working in. In contrast, the orientation values in the
Object Info Control Panel are determined in relation to
the world’s X, Y, and Z axes.

Setting an Object’s Dimension
You change dimension values in Object Info mode the
way you change position or rotation values.

Dimension values are determined relative to the
object. Changing the Z scale value, for instance,
always scales the object along its own Z axis,
regardless of its orientation.

If you enter a value of 0 (zero) in all the Dimension
value boxes, the object disappears. It still exists,
but becomes so thin that it is invisible.

Using the Object Info Panel to Lock Values

As mentioned earlier, LogoMoticon allows you to lock
the values of an object's position, orientation, or scale
using Object Info mode. Using a lock freezes that
value until you open the lock.




Locking can be helpful if you have a scene with marny
objects. It prevents you from inadvertently moving,
rotating, or scaling an object you didn't intend to
change.

Position Locks

Locking position values prevents an object from being
moved along an axis.
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Notice the lock icons on the values that are frozen.

To lock an object’s position:
e Click the lock next to the axis you want to lock.

The lock icon changes to the focked position,
preventing you from moving the object along that axis.
If you lock all three position axes, the object is
completely frozen in space. (The object is still free to
scale or rotate, however.)

To unlock an object:
* Click the lock again. Unlocking a lock lets you
move the abject along that world-relative axis.

Orientation Locks

You lock an object’s orientation in the same way you
lock its position—by clicking the orientation locks next
to the axes you want to lock. When an axis is locked,
the object cannot be rotated around that axis. If ali
axes are locked, you cannot rotate the object at all.
Unlocking an axis allows the object to be freely
rotated around that axis.

Dimension Locks

Locking an object’'s dimension is similar to locking its
position or rotation. By locking the dimension vaiues,
you can prevent an object from changing size along
its own X, Y, or Z axis.

Selecting Obscured QObjects

Sometimes it's impossible to select an object by
clicking it in one of the view windows (for example, if
an object is completely inside another object).
LogoMotion provides a solution to this problem by
allowing you to select from a list of overlapping
objects when working in a view window.

To select an obscured object:
1. Place your pointer over any object or group of
overlapping objects in a view window.

2. Hold down the Command/Ctrl key and click.

A pop-up menu showing available objects (based on
the pointer's position) appears.

Hold down the Command/Ctri key while
clicking to select the inner cube.
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This technique works best when you descriptively
name your objects. (For information about naming
your objects, see “Visibility” on page 54.) The other
ways to select obscured objects are

* Choose an object by name in the Sequencer. For
more information about the Sequencer, refer to
“The Seguencer” on page 79.

¢ Choose Object> Select Object and pick the item
from the pop-up.

* Select the object from the Object pop-up in the
Object info Control Panel.

Using Hierarchical Models

One of LogoMotion's powerful features is its ability to
attach objects together to form object “hierarchies.”
Building object hierarchies is a convenient way of
organizing your objects and creating complex models
out of simpler component parts. Changes you make
to a complex object, such as rotating it, affect all the
objects linked to it.

Creating Object Hierarchies

Object hierarchies are formed by attaching one or
more child objects to a parent object. A child is
dependent on the parent; the position and orientation
of the child are calculated relative to the parent, and
the locks that you apply to the child restrict its motion
relative to the parent. When you move the parent
object, the child or children always foliow. An object
may be the child of a parent, and at the same time be
a parent to another child that you hierarchically link to
it.

To attach an object to ancther object:

1. Open the Sequencer window by choosing
Windows> Sequencer.

The names of all the objects in the scene are listed in
the left side of the Sequencer window.
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Objects listed in the Sequencer.

2. Drag the name of the object you want to be the
child onto the name of the object you want to be the
parent.
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Object 2 is being dragged onto Object 1.
3. When the parent object's name is highlighted,
release the mouse.

The child object’s name appears indented under the
parent object’s name




) A Unlitled 2 TEmemme! 1 8.
fEeo [5]

HoR et s, 11

3]
0000 0100 0200 0300 O T

g : ) &

T T

Object 2 is now a child of Object 1.

The objects are now attached hierarchically. If you
use any of the manipulation tools in the scene on a
parent object, the child object(s) attached to it are
affected as well.

A child object can only have one parent object.
You can attach a child to a different parent; just
drag the child from the existing parent object to a
new object. The link to the previous parent is
automatically broken and the new object becomes
the parent object.

Unlinking Objects
Separating child objects from their parents is as easy
as attaching them.

To separate linked objects:
1. Open the Sequencer by choosing Windows>
Sequencer.

2. Drag the name of the child object you want to
free to a space between object names, above the
parent's name (so that no other object names are

highlighted).
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Breaking the link between Object 1 and Object 2.
3. Release the mouse button.

The object is separated from its parent and appears
in the object name list with no indentation.

Once an object is unlinked, it is no longer influenced
by the manipulation of other objects.

Resizing Object Hierarchies
The Scale toois provide a great deal of flexibility when
working with object hierarchies.

When you scale a parent object with the Uniform
Scale tool, any children of that parent scale in
proportion to the parent.

The Squash and Stretch tool ignores object
hierarchies. It works with individual objects only. Use
the Squash and Stretch tool to manipulate any object
individually, whether or not it is a part of an object
hierarchy.

When using this tool, the object is squashed or
stretched towards or away from the side of the
bounding box that you clicked.

Duplicating Objects

Duplicating objects can be a great time-saver when
arranging objects in a scene. When you duplicate an
object, LogoMotion makes an exact copy. All of the
original object's surface and animation information is
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copied and the duplicated object is placed in the
scene slightly offset from the original. If the object is a
parent object, any child objects are also duplicated,
retaining the same hierarchy

To duplicate an object:
e Choose Edit> Duplicate.
Or

¢ Hold down the Option/Alt key while dragging the
object with a Move tool

Manipulating Centerpoints

Every object in LogoMotion has a centerpoint. This
centerpoint is adjustable and allows you to control an
object in specific ways.

There are two different classes of centerpoints: object
centerpoints and world centerpoints. In the scene,
every object has a centerpoint that is used for rotation
purposes. These centerpoints can make objects
easier to controf during an animation.

The second type of centerpoint is the location of a
lathed or extruded object’s centerpoint, as defined in
the Workshop. This centerpoint is most useful when
designing objects and when controlling squash and
stretch effects for animation.

World Centerpoints

The world centerpoint for all objects is, by default, the
exact center of the object's geometry. You can adjust
this centerpoint by dragging the object in the world
while holding down the Control/F2 key.

As you move the object with the Control/F2 key held
down, you'll notice that the object moves, but the
centerpoint for that object is left behind.

Adjusting the world centerpoints is most useful for
controlling objects during an animation. For instance,
if you want the camera object to rotate around a
sphere while remaining focused on the sphere, you
can adjust the camera so that the centerpoint is
located at the center of the sphere and the Camera
object is located at a distance from this centerpoint.
Then, when you rotate the Camera, it will rotate
around the adjusted centerpoint, and revolve perfectly
around the sphere while continuing to aim towards it.

Object Centerpoints

Lathed and extruded objects have an object
centerpoint. This object centerpoint determines how
the model is built, and consequently, how it will react
to squash and stretch techniques for animation.

In each of the Workshops, you'll notice horizontal and
vertical axes that cross at 0, Q. This intersection is the
object’s centerpoint. If you design a wine glass with
the Lathe Workshop and you place the profile so that
it is centered on the horizontal axis, it will squash or
stretch evenly when you use the Squash and Stretch
tool in the scene.




Chapter 7

BEVELS AND SURFACES

Bevels and surfaces affect the outer layer of objects.
Bevels determine what the edge of an object looks
like and surfaces are the type of material that covers
. an object.

This chapter explains how to use bevels and surfaces
in LogoMotion.

What Are Bevels?

Bevels are curves or angles added to the edges of
cbjects. These edges help the object catch and
reflect light. When creating logos, bevels can give
objects (especially text objects) a feeling of elegance
or distinction.

A shape without a bevel.

A shape with a bevel.

In LogoMotion, you can apply a bevel to any text or
extruded object. Beveled cbjects can also be
metamorphosed or “morphed” over time.

LogoMotion offers five predefined bevel types. These
bevels can be added to objects and then customized.

Specifying Bevels with the Bevels Control Panel

By using the Bevels Control Panel, you can add a
bevel to any text object by simply dragging the name
of a bevel type from the bin and dropping it onto the
object in your scene.

Once an object has a bevel, you can customize it to
make as dramatic or subtle as you like. You have the
option of either numerically entering in the vaiue of the
bevel or manually positioning the bevel using the
Shape Control pop-up.

You can manually shape a bevel in the Shape Control pop-up.
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The Shape Control Pop-up

Clicking the Shape buttan in the Bevels Control Panel
automatically pops up an interactive diagram where
you can visually manipulate your bevel. Moving the
pointer towards the left of the diagram increases the
distance that the bevel extends from the object. The
maximum setting results in a very exaggerated bevel.

Dragging the pointer towards the bottorn of the
diagram increases the depth of the cut. The maximum
setting causes the bevel to stretch down, halfway
along the side of the object.

The Back Bevel Button
ﬂ - Clicking the Back Bevel button creates bevels
Backbevel on both the front and back halves of the
object, making it symmetrical. If this button is
off, the bevel appears only on the front face, leaving
the corners on the back face at 90 degrees. This can
save rendering time if your scene doesn't require the
back face of the object to be shown.

Applying Changes

After setting the bevel parameters, you must click the
Apply button in the Control Panel or press the
Return/Enter key for your changes to take effect.

The preview area, located beside the Back Bevel
button, shows the bevel type for the currently selected
item in the scene.

Other Ways to Add Bevels
There are two other ways you can add bevels to
objects:

* You can bevel a text object when you create it in
the Text dialog. The Text dialog contains options
for specifying the type of bevel and its size.

* You can place bevels on objects in the Extrude
Workshop.

Things to Keep in Mind About Bevels

Beveled objects need more RAM than non-beveled
ones and can take significantly longer to render.
Adding a bevel to an object physically changes the
geometry of the object. Large bevels can intersect
each other, or even other objects, which can often be
undesirable. Since you have control over the size of
the bevel, you can determine how much larger an
object will be when the bevel is added.

What Are Surfaces?

Creating an object and then applying a surface to it is
similar to the way a potter sculpts a bow! and then
applies a glaze. The surface, like the glaze,
determines what the finished object will look like. An
object’s surface is what gives the object its character.
LogoMotion provides flexibility and controt in creating
and editing surfaces.

Surfaces in LogoMotion are selected from a library of
predefined surface types. As you create new
surfaces, they are added to the surface list.

Surfaces are created and edited independently of
objects. LogoMotion treats surfaces and objects as
separate entities. Applying a new surface to an object
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will not affect that object’s shape or size. When you
edit a surface, the edited surface replaces the
previous surface globally, that is, on every cbject to
which you have applied that surface.

You can access the surface list in three ways:
» From the Surfaces Control Panel

* By choosing Options> Apply Surface

e From the Object Info Control Panel

Most often you'll use the Surfaces Control Panel to
perform surface editing tasks.

Applying a Surface with the Surfaces Control
Panel

The Surface Panel provides a convenient way to
apply surfaces to an object.
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To apply surfaces to an object:
1. Select a surface in the bin on the far right of the
Control Panel.

2. Drag that surface onto an object in your scene.
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Another easy way to apply a surface to a selected
object is to choose Options> Apply Surface, then
choose a surface from the list.

The solid surface of an object is not visible when the
object is rendered in Wireframe or Bounding Box
mode, only in Fast, Better or Best mode. However,
you save rendering time by working in Wireframe
mode when manipulating objects. LogoMotion
remembers an object's surface, no matter which
shading mode you're using.

Most likely you'll find that working in Wireframe mode
is best for setting up your scene. You can switch to
Fast, Better or Best mode to check how a particular
surface looks, then switch back to Wireframe mode. If
QuickDraw 3D is active, your objects will draw

quickly, but the shading isn't suitable for a final render.

For that, you should switch to Best mode.

Editing a Surface with the Surfaces Control Panel
The Surfaces Control Panel is central to the process
of creating and editing surfaces. With the Surface Info
dialog, you can rename surfaces, edit surface
properties, and preview the surface you're creating.
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Color/Map

The Color/Map button lets you create new
surfaces. When creating a surface, you have
the option of giving the surface either a color attribute
or a texture map.

Coloi/Map

Color
All the surfaces in the default surface tibrary (metals,
plastics, and neon surfaces), have a color attribute.

To assign a color to a surface:

1. Click the Color/Map button on the Surfaces
Control Panel.

The Surface Creation dialog appears, containing a
color picker.

2. Select a new color and adjust the brightness in
the color picker.

3. Click OK.

This sets the surface parameter and saves it in the
Surface bin on the right of the Control Panel. All
objects in your scene that use this surface update to
show this new change.

Map

Use a texture map if you have a 2D image that you
want to wrap onto a 3D object. This is a perfect way
to create surfaces other than metal, plastic, or neon
surfaces. Surfaces such as woods, marbles, and
fabrics can easily be created by using a 2D image or
QuickTime movie of that type of surface.

Images and movies saved in many different file
formats can be used as textures. PICT and QuickTime
files can be used as textures on Macintosh
computers, while PCs support TIF, BMP, JPG and
other image file formats.

On a Macintosh, if a QuickTime movie is used as a
texture, the movie autormatically plays on your
animated objects.

There are a few drawbacks associated with texture
mapping. Textures can only be seen in the highest
shading mode (Best). On top of that, rendering times
are significantly affected by adding textures. Often,
however, the effects that texture mapping producas
are so stunning that it is worth the wait.

To texture map a 20 image:
1. Click the Color/Map button on the Surface Control
Panel.

The Surface Creation dialog appears, containing a
color picker.

2. Switch the surface type from Color Map to Texture
Map.




The color picker disappears and is replaced with
texture mapping cptions.
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3. Click Get Texture File and choose the image from
the standard Open file dialog.

4. Press the OK button.

A new surface is added to the Surface bin with the
same name as the image file.

5. Change the shading mode in the Rendering
Control Panei to Best, otherwise you won't be able to
see the image mapped onto the object.

‘Mapping Methods

There are four different mapping methods: two that
are used for lathed objects and two that are used for
extruded objects. For each texture, you can specify a
mapping method for all lathed objects and all
extruded objects.

The mapping methods for lathed objects are

cylindrical and spherical.

- Cylindrical

@_ Use a cylindrical map to map a layer onto a
cylindrical object, such as a bottle, jar, or
baseball bat. This map type tells LogoMotion

to wrap the 2D surface layer around the 3D object.

A cylindrically mapped object.

Spherical

""’B This map type wraps the surface layer around
— an object, and “crimps” the top edges of the
layer together at the top of the object, and the bottom
of the layer together at the bottom of the object. This
is particularly useful for mapping images onto
spheres.

A spherically mapped object

The mapping methods for extruded objects are
cubical and straight.

Cubical
ﬁ A cubical map is intended specifically for use

» L3 . .

with cubes. Use a cubical map to apply a
copy of a surface layer to each of the six sides of a
cube.

A cubically mapped object.
D Straight
Use a straight map to apply a flat image to a
—— flat surface. This is useful for most extrusion
objects. Note that a straight map goes completely
thraugh an object in one direction. This can cause the
side to appear streaked: the image will also appear
backwards on the reverse side of the object.

A straight mapped object.

Surface Properties

Beside the surface name is a list of surface
properties, each of which can be adjusted with a
slider. Surface properties determine how a surface
responds to light. The surface properties you can set
are diffuse shading, specular highlight, metallicity, and
reflectiveness.

Diffuse Shading

Diffuse shading is the phenomenon by which light hits
an object and is uniformly scattered so that the whole
object is illuminated equally.

The result of 100% diffuse shading is that the object
appears smoothly shaded when a light shines upon it.
It's brightest in the direction of the light source,
completely in shadow opposite the light scurce.

The lower you set the percentage for diffuse shading,
the less illuminated the object will be. An object
rendered with a diffuse shading level of zero would
appear mostly black when rendered, aithough it could
stiif have reflective-like properties.

High Diffuse Shading

Low Diffuse Shading.
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Specular Highlight

This control affects the brightness of the object’s
specular highlight. A specular highlight is what you
often see as a smalf, round, white spot reflected from
a shiny object at the point on the object that is closest
to the light.

A specular highlight is essentially a distorted
reflection of the light source itself, so it generally has
the color of the light source. In reality, specular
highlights usually appear white, simply because
lighting in the real world is most often white. Metallic
surfaces such as copper, gold, and silver, however,
will have specular highlights that are the same color
as the object’s surface.

If you see an object with a very bright specular
highlight, you will immediately recognize that the
object must be smooth rather than rough.

High Specular Highlight.

Metallicity

A surface appears metallic when you adjust the color
of the specular highlight. The closer a surface’s
specular highlight is to the color of the surface, the
more metallic the surface will appear. (Try adjusting
the metallicity level yourself to fully understand its
effects.)

High Metallicity.
Reflectiveness

This control affects how well the object reflects the
environment: as you increase the percentage of
reflectiveness, the surface reflects more of the
environment. Reflectiveness affects the entire surface,
but it is not affected by the Specular Highlight
controls.

The interplay of environment maps and the
Reflectiveness setting can create dramatic effects.

7.35

High Reflectivensss.

The Preview Box

As you make changes to a surface in the Surface
Creation dialog, the surface updates in the Preview
Box. The sphere in the Preview Box always shows
updates to the current surface settings.

Duplicating Surfaces

To duplicate a surface on the Surface Control Panel,
go to the bin and select the surface you want to
duplicate. Then choose Options> Duplicate Surface
to produce a copy of the first surface with all the
same surface parameters.

Surface Libraries
You can use the Surface Library to duplicate, delete,

and preview surfaces. This dialog allows you to create
a surface list that is customized to your specifications.
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The Surface Library.

To cpen the Surface Library dialog box, choose
Options> Surface Library or press Command/Ctri-L.
Note that the Surface Library dialog contains a
scrollable, predefined surface list, a surface preview
box, and several control buttons.

Opening a Surface Library File

You can organize all your surfaces into your own
surface library files. As you create, edit, and add
more surfaces, the surface list can become unwieldy.
Creating a surface library can be a handy way to
keep the surfaces organized.
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The Surface Library with an opened Surface Library file.

Once you've created a surface library, open it by
clicking the Open Library button. Select the library
from the dialog that appears and click OK. When you
open a surface library file, a second surface list
appears opposite the existing list. This list represents
the surface(s) present in the file just opened. Once a
library is opened, you can duplicate, copy, rename,
edit, and delete surfaces in it.

Making a New Surface Library

You might want to arrange surfaces into groups,
especially if you have created lots of new surfaces.
Click the Open button, then click the New button in
the dialog box that opens. LogoMation places an
untitled surface library list opposite the list of surfaces
in your current scene. Simply use the Copy button to
copy surfaces back and forth. To save your new
library, click the Close button and specify a name for
the library when prompted.

Selecting a Surface
Click a surface in the surface list. The surface begins
to render in the preview box.

Duplicating a Surface

Select any number of surfaces and click the Duplicate
button. All the selected surfaces are duplicated in the
surface list. Duplicating a surface is useful if you want
to edit a surface without changing the original
surface.

Renaming a Surface

Selfect a surface and click the Rename button. A
dialog box appears where you can enter a new name
for the surface. The surface White Plastic cannot be
renamed.

Deleting a Surface

Select the surface(s) you want to delete from the
surface list. When you click the Delete button, all
selected surfaces are deleted. The surface White
Plastic cannot be deleted.

If you delete a surface that is still applied to an
object, that object’s surface reverts to White
Plastic.

Get Image

Click Get Image to load an image or movie file into
the surface library. A dialog appears where you can
specify the image or movie to load.

Copying Surfaces
Select the surface or surfaces you want to copy from
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one surface list to another. Then click the Copy button
in the Surface Library dialog box. The selected
surfaces are copied into the opposite surface list.

Closing Surface Libraries

Once you've finished working with a surface library
file, click the Close button. If you copied new surfaces
into the, surface library file, LogoMotion asks if you
want to save changes to that file.

Select Unused

Clicking Select Unused highlights all the surfaces on
the lett side of the dialog box (the surface list for the
current scene) that are not currently in use. This can
be useful if you want to clean up your surface list.
After selecting the unused surfaces, peruse the list to
ensure you don't want to keep any of the highlighted
surfaces in that scene, then click Delete to remove the
unused surfaces.
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Chapter 8
LIGHTING AND ATMOSPHERE
Introduction

You can have a scene full of complex objects that
you've spent a lot of time creating but they'll look a bit
boring unless you create a mood by adding lights and
atmospheric effects to your scene.

Lights

Lights in LogoMotion are moveable, editable objects
that are actually visible in the scene. Lights are
manipulated the same way that other objects are.
They can be repositioned with the Move tools, scaled
with the Scale tools, and rotated with the Rotate tools.

You can have as many light sources as you like and
you can individually adjust the position, arientation,
and color of each. Having the ability to manipulate
light objects directly gives you a great deal of control
and flexibility in setting up scenes and animations.

Types of Light Sources

There are three types of light sources in LogoMotion:
point lights, spotlights, and ambient light. Point lights
and spotlights are both represented by light objects.

You place them into the scene and manipulate them

just like other objects. Point lights cast light evenly in
all directions; spotlights are directional. Both types of
light objects can cast light of any color.

Ambient light exists evenly throughout the 3D world.
Ambient light is sourceless; that is, it does not
emanate from a light object. You can change the
ambient light by changing settings in the Atmosphere
Control Panel. Refer to "Ambient Light Color” on page
75 for details on changing ambient light.

Lighting effects aren't visible on objects in Wireframe
or Bounding Box modes.

Default Lighting

When you create a new scene, by default two sources
of light exist to illuminate objects: one point light,
generically called “Light,” and ambient light, which is
set to a moderate level.

Adding New Lights

You can add as many lights to your scene, in any
combination you like. You're only limited by the
resources of your computer. You add lights using
StageHands.

You can add either a point light (to cast light evenly all
around) or a spotlight (to cast light in a specific
direction).

Be aware that increasing the number of lights in the
scene is also likely to increase rendering time.

To add a light to the scene:

1. Switch to the StageHands Control Panel and click
the Lights button.

2. Scroll the list of lights in the Light bin until you
find one you like.

3. Drag a light from the bin and drop it into your scene.
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Tip: You can also add lights by copying and
pasting existing lights, or by selecting a light and
choosing Edit> Duplicate.

Naming Lights
As you add more and more lights 10 a scene, you
might find it helpful to name them. This helps avoid
confusion when moving lights, particularly in
animation sequences. StageHands lights already
have names, but you can change them.
To name a light object:
1. Select the light by choosing Options> Select
Object> Light.
2. Choose Options> Edit Object.
3. The Light Info dialog appears.
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The Light info dialog.
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4. Enter a new name for the light in the Name field,
then click OK.

You can also change a light's name in the Object Info
Control Panel.

Positioning and Orienting Lights

Lights, like other objects, are positioned and oriented
with any of the Move or Rotate tools, or by entering
numerical coordinates in the Object Info Control
Panel. Refer to “Arranging Objects in Your Scene” on
page 53 for information on how to use the tools.

Here are some pointers about working with lights in
your scene:

* Lights are often set far back from the objects in
the scene. For this reason, it's easiest to change
their position and orientation in the standard view
windows.

*  When trying to move or rotate a light, be sure
your pointer is directly over the fight object.
Otherwise, it might seem that the tools aren’t
working properly.

* |t's often useful to zoom in close to a light object
so that you can more accurately rotate or move it.
You'll probably need to switch between the
Magnifying Glass tool and the Hand tool a few
times to get in close enough to the light object.

¢ Changing the size of light objects has no effect
on the light that they cast.

¢ Double-clicking a light causes the Light Info
dialog to appear, where you can set intensity and
color options. Double-clicking can be difficult,
however, if the light object appears very small in t
the view. If this is the case, choose Opticns>
Select Object> Light, then choose Options> Edit
Obiect.




Aiming Spotlights Automatically

LogoMotion can point a spotlight at any object in the

scene. The Point At command points the spotlight at

the visual position of the object in the scene. If you
move an object away from its centerpoint, the Point At
command takes this intc account and points at the
object itself, not its centerpoint.

To point a spotlight:

«  With a spotlight selected, choose Options> Point
At, then choose the object you want the light to
point at from the list of objects.
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Changing Lighting Effects
Once you add lights to your scene, there are several
ways you can control their effects.

Changing the Type of Light
You can switch a point light to a spotlight and vice
versa.

To change the type of light:
1. Select the light by choosing Options> Select
Object> Light.

2. Choose Options> Edit Object.
The Light Info dialog appears.

3. Click the appropriate button to select either a
point light or a spotlight, then click OK.

Making Lights invisible

As you set up your scene, there will be times when
you want a light object to cast light, but you won't
want to see the light object itself in the scene. You
can make light objects invisible but still see the light
they cast.

To make a light invisible:

1. Select the light by choosing Options> Select
Object> Light.

2. Switch to the Object info Control Panel.
3. Click the Visible button in the panel.
4. The button label changes to Off.

You can see the effect of the light on the objects in
the scene, but you won't see the light itself.

Some StageHands lights are already invisible.

Changing Light Color and Brightness
Another way you can affect the illumination of a scene
is to change the color and brightness of light sources.

The color value lets you choose aimost any possible
color for the light. The intensity value determines the
brightness of a given light relative to other lights in the
scene. Values can be less than or greater than 100%.
For example, to make a light extremely bright, try

using a value of 300%.

To change the color and brightneu:. of a light:
1. Select the light by choosing Oplions> Select
Object> Light.

2. Choose Options> Edit Object.
The Light info dialog appears.

3. Click the Color pop-up and choose a color from
the color picker.

The preview changes to show you the color of the
light.

4. Set a brightness for the light by changing the
value in the Intensity field.

5. Click OK.

Lights in a LogoMotion scene have a cumulative
illumination effect. Too many bright lights can
cause objects in the scene to appear washed out.
When adding a new light source, consider if you
need to decrease the intensity of the other lights
in your scene.

Casting Shadows

In the rea! world, an object in the path of any real light
casts shadows. In LogoMotion, however, you have the
option of preventing this behavior.

Turning shadows off can be useful, for exampie, if you
want to illuminate an object from a particular direction
but don’t want the object to cast shadows from that
light source upon adjacent objects. In theater design,
this would be similar to the effect of a “fill” light, a light
used to brighten dark areas without causing more
dark areas.
You can turn shadows off or on for individuals objects:
* An object with shadows turned off (in the Object
Info Control Panel) won't cast shadows on other
objects.
¢ A light with shadows turned off (in the Light Info
dialog) prevents objects from casting shadows
from that particular light. However, other lights
might cause those objects to cast shadows.

To turn off shadows for a light object:
1. Select the light by choosing Options> Select
Object> Light.

2. Choose Options> Edit Object.
The Light Info dialog appears.

3. Clear the Cast Shadows checkbox, then click OK.

You can only see shadows in Best shading mode.

Deleting Lights

Too many lights in your scene can make the scene
look flat, as well as increase your rendering time, so
you shouid remove any lights you're not using in your
scene.

To remove a light from the scene:
1. Select the light by choosing Options> Select
Object> Light.

2. Press the Delete kuy.
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LogoMotion removes the light from the scene.

Atmospheric Effects

You can create artistic effects in your scene by
manipulating LogoMotion's atmospheric settings. You
control a scene’s background color, ambient light, fog
settings, and environments from the Atmosphere
Control Panel.

u B

Ambleat Fog
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Amncaphers Background

The Atmosphere Control Panel.

Background Color

When you launch LogoMotion, the background color
is black. This black background color can be
changed at any time to any color you like.

To change the background color:
1. Switch to the Atmosphere Control Panel.

2. Click the Background Color swatch and choose a
color from the color picker that appears.

The background changes to the color you chose.

If you add a backdrop to a scene, it overrides any
background color you specify. If you remove the
backdrop, the background color reappears.

Ambient Light Color

Ambient light is light that exists everywhere without a
particular source. This light does not cast shadows
but fills in the shadowed areas of a scene.

To change the color of ambient light:
1. Switch to the Atmosphere Control Panel.

2. Click the Ambient Light swatch and choose a
color from the color picker that appears.

The ambient light changes to the color you selected.

The effects of changing the ambient light color
can be quite subtle. Don’t be afraid to experiment
with this setting until you achieve the look you
want for your scene.

Fog

Adding fog to your scene can add a realistic
atmosphere, giving the objects in your scene a sense
of depth. Setting the fog’s visibility level determines
how far you can see into the fog. Beyond the visibility
point, objects are lost in the fog.

To add fog to a scene:
1. Switch to the Atmosphere Control Panel.

2. Move the Fog Depth slider to the level of visibility
you want.

The higher the value in the slider, the more fog you
add to the scene; the lower the value, the less fog.

The fower the setting in the Fog slider, the higher the visibility.

The higher the setting in the Fog slider, the lower the visibility

You can view the effect of fog in your scenes when
shading mode is set to Fast, Better, or Best. However,
you can't view fog when QuickDraw 3D is active.

The fog color is determined by the background
color. In reality, you can only see a certain
distance into a foggy atmosphere, beyond which
all you see is the color of the fog. In the case of
rendering a 3D scene, this would be equivalent to
the background color.

Environment Mapping

When you look at a shiny sphere, it reflects its
surroundings. No matter how you rotate the sphere,
the position of the reflections stays constant, but if you
move the sphere through space, the reflections on its
surface change as it moves through the environment.

Environment mapping simulates reflections by taking
a picture (also called an “environment map”) and
mapping it onto reflective objects so that it appears
that the object is reflecting an environment. This
picture is not associated with a particuiar object, but
with the entire scene. Any object in the scene with a
reflective surface will automatically reflect the
environment map.

A scene without an environment map.

A scene with a water envirorment map.

To add an environment to your scene:

e Select an environment from the bin in the
Atmosphere Control Panel and drag it to the
scene.
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To remove an environment:

» Drag the None environment from the bin in the
Atmosphere Control Panel and drop it into the
scene.

Creating Your Own Environments

You can use any valid image or movie file as an
environment for your scenes. Just place the file in the
LogoMotion: StageHands: Environments folder on
your hard drive. Then all you have to dois drag it to
your scene to use it.

Valid file types for environments are:
«  On Macintosh: PICT, PICS, and QuickTime
movies

e  On PCs: AVI, BMP. JPG, PSD, and other common
formats

Tip: You can use animated environments for
dynamic animated effects in your scenes.For
example, if you want moving clouds to reflect on
ohjects as an environment, you could use a
QuickTime movie of clouds. You can use PICS
files, QuickTime movies or AVI files as
environments. Be aware, however, that using large
movies will significantly slow down LogoMotion’s
performance.

Backdrops

Backdrops are ancther way to add atmosphere to
your scenes. You can stage the objects in your scene
against of background of cloudy sky for example.

A backdrop appears behind the objects in your scene.

Backdrops differ from environments in that you
actually see the image of a backdrop as the
background for your scene. The backdrop appears
behind the objects in the scene, but does not reflect
on the objects. With an environment, you never see
the image, only its reflection on reflective objects.

LogoMotion provides a variety of ready-to-use
backdrops in the StageHands Control Panel.

To add a backdrop:
1. Switch to the StageHands Control Panel.

2. (Click the Backdrops button.

3. Choose a backdrop that you like, then drag it
from the bin to your scene.

The backdrop appears behind the objects in your
scene.

You can use your own images and movies as
backdrops. Just place them in the LogoMotion:
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StageHands: Backdrops folder on your hard drive.
Then, the next time you launch LogoMotion, the
images wiil appear in the Backdrap bin in the
StageHands Control Panel.

Cr, for Macintosh users, drag your image file from the
desktop or Scrapbook into the Camera View to have it
appear as a backdrop for your scene.

valid file types for backgrounds are:

e« On Macintosh: PICT, PICS, and QuickTime
movies

s  On PCs: BMP, JPG, PSD, and other commeon
formats.
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Chapter 9

ANIMATION

Animation Overview

One way to add animation to your scenes is to use
LogoMotion's StageHands, but you can aiso create
and control your own animations.

LogoMotion's animation approach is time-based, or
“event-driven.” In LogoMotion terms, an event occurs
each time you change the position, orientation, scale,
shape, or surface characteristics of an object.

LogoMotion individually tracks every event that
happens to every object in your animation. These
events are plotted in time along object timelines.
Every object in a scene has its own timeline; each
timeline shows a complete history of every event that
happens to that object.

Whenever an event occurs to an object, LogoMotion
places an “eventmark” on that object's timeline at the
precise moment that the event happens. These
eventmarks and timelines appear in LogoMotion's
special Sequencer window. Using the Sequencer, you
can add, delete, copy, and rearrange eventmarks.

Refer to “The Animation Sequencer” on page 15 for
general information about the Sequencer.

The Sequencer

The Sequencer is the heart of animating your scenes
in LogoMotion. It's where you change your scene from
a static collection of objects to a dynamic, changing
movie.

The Sequencer lets you track time and preview your
animation seguences. It's where you add or delete
events, and helps you keep track of the components
of complex models.

To open the Sequencer:
* Choose Windows> Sequencer.

Time Tracker

The Time Tracker displays the time of an animation in
minutes, seconds, and frames (from left to right). You
can change how the Time Tracker shows time by
clicking the pop-up menu beside the Time Tracker
and choosing a new display setting. (When you
change the setting, the Timebar changes as well to
reflect the new setting.)

Punch In/Punch Out Markers

Punch In/Punch Out markers appear above the
Timebar and can be used to minimize your rendering
time by letting you select only a specific portion of an
animation to render. If, for instance, you don't have
time to render a lengthy animation, you can use the
Punch In/Punch Out markers to render portions of it
as time allows.
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You can slide the markers to any point in time. Once
set, LogoMotion animates only the frames that lie
between the two.

If you manipulate objects in time past the Punch Qut
marker, the Punch Out marker automatically moves to
the time when the new eventmark is created. When
making a movie, LogoMotion defaults to animating
between the Punch [n/Punch Out markers.

The Object Name List

Ob ject Name
Camers
Light
Extrude Object

On the left side of the Sequencer is the Object Name
list where the names of all objects in the scene
appear. Clicking an object's name in the list selects
that object in the list, as well as in the scene itself. In
fact, selecting an object in the Object Name list is
cften the easiest way to select an object in a complex
scene where it's hard to pick out individual objects.

You can see hierarchical refationships between
objects in the Sequencer. Child objects are indented
and listed beneath their parent objects.

The Timebar

01.00 02.00
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The Timebar across the top of the Sequencer window
shows world time. World time begins at Time 0 and
reads from left to right across the Sequencer. World
time can be shown in minutes, seconds, or frames of
animation; you change the type of display with the
Time Tracker.

You can change the increments that appear in the
Timebar to show a finer or grosser level of detail.

To change time increments in the Timebar:

¢ Click the + {plus) or — (minus} to the right of the
Timebar to increase or decrease the level of
detall in time increments.

The World Time Marker

=

The World Time Marker is a pointer you can drag
through time. It extends down through all the objects
in the Object Name list.

The position of the World Time Marker determines the
“current” time in the world. All objects in the scene are
shown in relation to the World Time Marker. That is,
objects might be in one position at one point in time
and at ancther position at another point in time. The
World Time Marker shows you how objects appear in
a scene at a specific point in time. Keep in mind that
you are always editing the moment in time tc which
the World Time Marker currently points.




To move the World Time Marker:
*  Click the World Time Marker and drag it to a
different moment in time.

LogoMotion redraws the scene to show any changes
that happen at the new moment in time.

The World Time Marker moves through the Timebar
when you preview or animate a sequence. You can
specify that the marker stay where it is or return to its
original position after a preview or animation.

To specify World Time Marker preferences:
1. Choose Edit> Preferences.

The Preferences dialog appears.

2. Click Return to Original Time if you want the
World Time Marker to return to its original position. (By
default, LogoMotion leaves the marker where it is after
a preview, unless you specify otherwise.)

3. Click OK.
The Object Timelines
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Every object in the scene has an object timeline in the
Sequencer. The timeline for each object begins at
Time 0O, which you can see just to the right of the
object name, and runs from left to right beneath the
Timebar. Here is where all the changes (events) you
make to an object are plotted along world time.

Whenever you alter an object, an eventmark is placed
on that object’s timeline at the exact point in time
where the World Time Marker is pointing.

Each timeline shows a complete history of all events
that have occurred to that object throughout world
time.

Eventmarks
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An eventmark is a graphic representation of an object
at a particular moment in time. Whenever you move,
scale, add a surface to, or otherwise change an
object in the scene, LogoMotion places an eventmark
on that object's timeline at the current position of the
World Time Marker.

The Basics of Animation

Animations are created by adding and manipulating
eventmarks along the timelines. Eventmarks can be
added, deleted, edited, duplicated, and moved along
the object timelines.

Selecting Eventmarks

You can select an eventmark just by clicking it on an
object timeline. When selected, an eventmark is a
dark gray. (Unselected eventmarks are a light gray.)
You can select multiple eventmarks and manipulate
them simultaneously.

To select multiple eventmarks:

* Hold down the Shift key while clicking the
eventmarks you want to manipulate.
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¢ Drag a marquee around the eventmarks. This lets
you drag across object timelines.
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Selected eventmarks are dark gray.

Adding Eventmarks

Whenever a change of any kind occurs in the scene,
LogoMotion places an eventmark at the current
position of the World Time Marker. Adding an
eventmark is a matter of moving the World Time
Marker and making a change within your scene.
LogoMotion does the rest and adds an eventmark to
the timelines.

To add an event:

1. Drag the World Time Marker to the moment where
you want to change an object. (This is where you want
the event to be added.)

2. Move, rotate, or scale the object the way you
want.

LogoMotion adds a new eventmark on the object’s
timeline at the paoint where the World Time Marker is.

LogoMotion also automatically adds an eventmark if
you change an object's surface, size, or shape.
Eventmarks are also automatically added if you
change the focal length of the camera’s lens (using
the Magnifying Glass tool), or if you change the color
of a light.

Camers
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A text object in a scene and the Sequencer.
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Rotating the text object causes LogoMotion to add
an eventmark at the location of the World Time Marker.

Moving Eventmarks
Eventmarks can be moved to any point on a timeline.
Move an eventmark by dragging it.
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The eventmark’s original position.
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Here, the eventmark is dragged o a new position in time.

When you move an eventmark, you change the
moment in time at which that specific event occurs.
Moving an eventmark also changes the length of time
between two events. If you want events to occur later
in time, all you need do is select the eventmarks that
you want to move and drag them farward in time
along the object timeline. The events will then take
place later in the sequence.

Duplicating Eventmarks

It can be handy to duplicate eventmarks or groups of
eventmarks. For example, duplicating eventmarks is a
good way to create looping motions (like wheels
turning or balls bouncing) throughout your animation.

Any eventmark can be duplicated.
To duplicate an eventmark

1. Select the eventmark(s) you want to duplicate.

7.43

[ e e e e 1] - |

3]
oot [ {wm nm om am mo

ey 108

[ !

D i ,;

1
!
H
Before the eventmarks are duplicated.

2. Hold down the Option/Alt key and drag the
eventmark(s).

I T T T

3. Move the duplicated eventmark(s) to the new
position
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After the eventmarks are duplicated.

Deleting Eventmarks

There will probably be times you want to delete an
eventmark. In fact, deleting an eventmark is a
convenient way to eliminate any change in the scene
you're not happy with.

To delete an eventmark:
1. Select the eventmark(s) you want to remove.
2. Hit the Delete key or choose Edit> Clear.

The eventmark, and all animation information
associated with it, is deleted.

If you're not sure which eventmark represents which
event, move the World Time Marker to that eventmark,
then look at the object in the Camera View to see
what the event is.

You cannot delete all of an object’s eventmarks. If
you delete the last eventmark, LogoMotion adds
an eventmark at the current position of the World
Time Marker.

Squashing and Stretching Animations

When creating an animation, you might want to
change the overall time it takes for multiple events to
happen. With LogoMation, you can “sguash” or
“stretch” an animation over time. Squashing or
stretching an animation is proportional; the events
themselves don't change, they just take place in a
shorter or longer period of time.

To squash or stretch an animation:

1. Select the eventmarks for.the animation you want
to change.
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The original animation sequence.

2. Hold down the Command/Ctr! key while dragging
the last selected eventmark.

Dragging left squashes the animation; dragging right
stretches it.
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After squashing the animation sequence.

You can also squash or stretch the animation of a
hierarchical object—a parent object that has children
linked to it. (Refer to “Using Hierarchical Models" on
page 57 for more information on hierarchical
relationships.)

To squash or stretch a hierarchical object’s animation:
1. Click the triangle icon to the left of the object’s
name in the Object Name list.

Make sure that the list of child objects is completely
expanded.
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Click the triangle icon to expand the list of linked objects.
2. Select the eventmarks of the parent and child

objects by dragging a marquee around all the
eventmarks.

3. Hold down the Command/Ctrl key and drag any
object’s last selected eventmark to the left or right.

The eventmarks you selected evenly squash or
stretch in time to match the last eventmark.
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Before and after squashing the timeline.

Previewing an Animation

As you work on animating your scene, periodically
you'll want to preview it to get an idea of how it wili
look when it's rendered.

To preview an animation:
* Choose Animate> Preview.

Or

* Drag, or “scrub," the World Time Marker back
and forth.
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Dragging the World Time Marker back and forth
/s one way to preview an animation.
Tip: If you hold down the Option/Alt key while
scrubbing the World Time Marker, the Camera View
previews the animation in the current shading
mode. This works particularly well when Quick
Draw 3D is enabled.

More on Animation

There are many ways you can fine-tune your
animations in LogoMotion. You can manipulate
individual eventrnarks to create sophisticated
animations, and you can metamorphose—"morph"—
surfaces and objects. When you morph an object,
LogoMotion makes a smooth, seamless
transformation between the object’s two states.

Controiling Eventmark Properties

For each eventmark in an animation, you can adjust
the type of motion path it uses. You adjust these
settings in the Eventmark Info dialog.

To access the Eventmark Info dialog:

*  Double-click any eventmark.

Or

* Choose Animate> Eventrmark Parameter.
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The Eventmark Info dialog
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Spline-Based vs. Linear Motion Paths

As an object moves in the 3D world, it can either
move linearly (in straight lines) or smoothly (using
spline-based motion).

A linear motion path is sharp and has angular
corners. When the object on a linear motion path
changes direction, it does so abruptly, like a robot.
Use a linear motion path if you want sharp, robotic
movements.

A spline-based motion path is very smooth, even, and
rounded. For smoother, more natural movement, use
spline-based motion.

If an object changes during the time between two
eventmarks, the two eventmarks are connected by a
motion path indicator. This indicator shows the type of
motion path the object uses between the two
eventmarks. If the indicator shows a solid bar
between events, the motion path is linear. If the
indicator shows a wavy line, the motion path is spline-

based.
=~
| |

Linear motion path Spline-based motion path

To choose the type of motion path:
1. Double-click the eventmark that starts the motion
you want to control.

The Eventmark [nfo dialog appears.

2. Click either the Linear button or the Spline-based
button, then click OK.

The type of path you chose is reflected in the object
timeline.

Ending Animation

You can make an object appear and disappear
instantly over the course of an animation. The
technigue of making an object disappear is known as
“ending animation.” If you check this option in the
Eventmark Info dialog, an object disappears from the
scene between the selected eventmark and the next
regular eventmark. End animation events appear in
the Sequencer as rectangular marks instead of oval.
Also, the motion path following an end animation
event appears as a black line in the timeline.

End animation events doesn't affect the camera. Even
though an object may have disappeared, the camera
still performs its functions.

To make an object disappear during an animation:
1. Select an object's eventmark in the timeline where
you want the object to disappear.

2. Double-click the eventmark.
The Eventmark Info dialog appears.
3. Check End Animation.

You can toggle this setting on and off for different
eventmarks to make objects disappear and reappear.
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Controlling the Splines in a Motion Path

You can control how a motion path passes through an
event by manipulating the Spline Control sliders in the
Eventmark info dialog.

* The Tension setting determines how tight or loose
the motion path is. A value of -100 causes an
exaggerated curve, while a setting of 100 makes
it appear almost linear.

¢ The Bias setting determines at what point, relative
to the corresponding event, the curve reaches its
maximum peak. A value of -100 causes the curve
to peak far ahead of the event, while a sstting of
100 makes it peak after the event.

*  The Continuity setting cantrols how evenly the
object passes through the event. A value of -100
results in sharp and constant motion, while a
setting of 100 results in an almost unnatural break
or discontinuity.

Jo control how a motion path passes through an
event:

1. Select the eventmark where you want to control
the motion path.

2. Double-click the eventmark.
The Eventmark Info dialog appears.

3. Adjust the Spline Control sliders to achieve the
effect you want.

4. Click OK.

Lining up Eventmarks

Holding down the Shift key while dragging either the
World Time Marker, the Punch In/Punch Out markers,
or the eventmarks causes them to exactly align, or
“snap," to other eventmarks. This makes it easy to
look at the precise point at which an event occurs in
the scene.

When dragging the World Time Marker, it can te
difficult to land precisely where an eventmark exists.
This means that if you're editing an event, you might
inadvertently place the World Time Marker just slightly
ahead of or behind the event. This creates another
eventmark next to the first (which will appear to
overlap it) and your animation will not behave the way
you intended.

You can avoid this situation by holding down the Shift
key when you drag the World Time Marker. This
causes the World Time Marker to precisely snap to
surrounding eventmarks. This ensures that the edits
you make will happen at exactly the time you want
them to happen. :

Animating Lights .

You can create animated lighting effects such as
changing a light source from one color to another.
When you create this type of animation, LogoMotion
fills in, or interpolates, the gradiations between the
two colors. This creates a smooth transition of color
during the animation rather than an abrupt change.

To interpolate a light's color:
1. Set your light source to any color.




2. In the Sequencer, move the World Time Marker to
a point later in time.

3. Change the light source to a new color.

LogoMotion creates an eventmark for the light,
showing that the light is changing.

These same guidelines apply to other lighting effects
you want to animate.

Surface Morphing

With LogoMotion, you can morph between any two
surfaces, creating animated sequences showing one
surface changing into another surface. Surface
morphs are created in the same manner as all other
animation sequences.

To morph between surface types:
1. Apply a surface to an object.

2. Move the World Time Marker later in time.
3. Apply a new surface to the object.

Object Morphing

You can have two objects morph from one into the
other. You can morph between any two lathed objects
or any two extruded objects. A point-to-point
correspondence between the two objects is not
necessary. You cannot, however, morph from a lathed
object to an extruded object.

You can use the Extrude or Lathe Workshop while

creating animations to make complicated objects
morph from one shape to another.
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The original shape before morphing.
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The shape during a morph.

The final shape after morphing

To morph between two objects:
1. Create a lathed or extruded object.

2. Moaodify the object with the Workshop and return to
the scene.

3. Move the World Time Marker later in time in the
Sequencer.

4. Reshape your object in the Workshop, then return
to the scene.

5. Select Detailed Preview from the Animate menu
to view the sequence.

Freezing an Object's Shape Using Edit Global
Shape

The previous section described how to edit an object
in order to morph it from one shape to ancther.
Sometimes you might want to edit an object and have
the changes take effect at all eventmarks for that
object.

Double-clicking on an object allows you tc change its
shape at only the current time in the Seguencer, which
results in a metamorphosis if the object has other
events. However, choasing Options> Edit Global
Shape lets you enter the Workshop and edit the
object's shape for every event on the object's timeline,
in effect, freezing the object's shape throughout the
animation. This action cannot be undone, but you can
reshape the object for the entire animation by
choosing the command again.

3D Text Morphing

Text morphing is an exciting way to animate between
text shapes. You can set up the animation to morph
one word into ancther.

Text objects can be morphed without regard to the
number of letters in the starting and ending words.
For instance, you could go from the word “egg” to the
word "baseball” without having to worry about
constructing the five extra letters—LogoMotion -
automatically adds them. Morphing looks best when
interpolating between words of equal length, however.
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The shape duyring a morph.

The final text shape after morphing.
To morph text objects:
1. Create a text object in the scene using the Text
tool in the Toolbox.

2. Move the World Time Marker forward in time in
the Seguencer.

3. Using a manipulation tool, double-click the text
object in the scene.

4. Type in a new set of letters or words (you can
also select a new font and extrusion depth), then click
OK.

You cannot morph bevels over time. The last bevel in
effect in world time is used during the morph.

5. Aneventmark appears in the text object’s
timeline.

6. Click in the Camera View and choose Animate>
Detailed Preview to preview the morph.

Tip: Make sure the QuickDraw 3D is turned on to
speed up detailed previews
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Chapter 10
RENDERING

Introduction

Rendering is the process of combining ali the
parameters you set for your 3D scene and producing
2D images based on those parameters.

You can capture a moment in your animation, render it
individually, and save it as an image file. Or you can
render all the moments in your animation and have
them render as a movie.

You set rendering options in the Rendering Control
Panel.
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The Rendering Control Panel.

Shading Methods

Shading is a technique that allows you to quickly
visualize solid models. Shading is what gives your
scene substance when you render it.

LogoMoation gives you five types of shading that offer
differing degrees of quality. The higher the guality of
shading you select, the longer it takes LogoMotion to
draw the image. You choose the shading method you
want from the Rendering Control Panel.You can save
time by using the lower guality (yet faster) shading
methods while building your modetls, and only using
higher quality (slower) shading methods when you
want to test texture maps, atmosphere or environment
effects, or to generate a final image or animation.

Choosing a Shading Mode

When you choose a shading mode, objects are
shaded in the Camera View only. The standard views
show you objects in Wireframe mode.
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To select a shading mode:
1. Switch to the Rendering Control Panel.

2. (Click the Quality button and choose a shading
mode from the pop-up.

LogoMotion redraws the objects in the scene in the
mode you specified.

The following sections describe the different types of
shading modes.

Bounding Box
Bounding Box mode is the simplest and
M fastest of LogoMotions shading modes. Each
object is represented by a six-sided box.
Bounding box mode is most useful for rough
placement and animation previews.

Objects in a scene shown in Bounding Box mode.
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Wireframe

When you view a scene in Wireframe mode,
you only see the polygons that make up the
object. Wireframe provides a good
compromise between detail and speed while you are

creating your scene. This is the default shading mode.

Objects in a scene shown in Wirefrarne mode.

Fast (Flat Shading)

Fast mode shows one color per polygon, or
face. It does a good job of quickly showing
the effects of lighting and basic color
information. Depending on the type of machine you're
using, this may also be a good mode in which to do
most of your work.

Obfects in a scene shown in Fast mode.

Better (Gouraud Shading)

Better mode takes a little longer to draw than
flat shading, but creates more realistic
surfaces with smooth edges (where

appropriate) and more realistic lighting and
atmosphere effects. This mode is perfect for when you
need a high quality image, but don't have the time to
render it in Shade Best. :

Best mede is the highest quality rendering

3 mode. It takes the most amount of time to

produce an image, but it's worth the wait when

you're producing your final image.This mode creates
very realistic surfaces including texture-mapping,
realistic lighting complete with shadows, and range of
atmospheric effects. Because of the time it takes to
draw onscreen, you probably won't work in this mode
very much. Instead, wait and use it for producing the
highest-quality work.
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Objects in a scene shown in Best mode

Shadows
MY If the Shadows option in the Rendering
shadows CONtrol Panel is turned on, objects will cast
shadows when rendered in Best mode. If this
option is turned off, no shadows will be cast for any
objects, even if those objects are checked to cast
shadows. Turning on shadows greatly increases the
length of rendering time.

Shadows turned off.

In order for shadows to be cast, each object in the
scene must be individually set to cast shadows (in
the Object Info Contro! Panel) and each light
source must be set to cast shadows (in the Light
Info dialog) as well.

To turn shadows on or off for rendering:
* In the Rendering Control Panel, click the
Shadows button to toggle the setting on or off.

QuickDraw 3D
Q Clicking the QuickDraw 3D icon in the
Rendering Control Panel causes LogoMotion
to use QuickDraw to shade the objects in the

qo3D

world.

Quick Draw 3D is a 3D renderer that is usually already
present on most Macintosh computers. QuickDraw 3D
is aiso available for Windows users and is
automatically installed when Windows users install
LogoMotion.

With QuickDraw 3D enabled, shaded, texture-mapped
objects can be manipulated in real time. This
eliminates waiting for the Camera View to update after
manipulating an object. QuickDraw 3D does not
support anti-aliasing. However, QuickDraw 3D
provides fast rendering when you're working in the
scene, but the quality isn't good enough for final
rendering.
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To use QuickDraw 3D:
¢ In the Rendering Control Panel, click the QD3D
button to toggle the setting on or off.

If the QuickDraw 3D button is dimmed, it is not
active on your computer. If you're using a
Macintosh, be sure the Quick Draw 3D extensions
are in the Extensions folder. if you are using a PC,
be sure the Quick Draw 3D DLL files are in the
LogoMotion folder.

) Anti-aliasing

E;J Anti-aliasing smoothes the edges of images,
anti-alies  rermoving the jagged appearance of diagonal

lines. Although anti-aliasing can be a time-

consuming process, it can produce an image of
superior quality.

An object without anti-aliasing. Notice the stair-step effect
along the edges of the cube.

An object with anti-aliasing. Notice the smoother edges of the cube.

To use anti-aliasing:
* Inthe Rendering Control Panel, click the Anti-
Alias button to toggle the setting on or off.

Anti-aliasing only takes effect when your scene is
shaded in Fast, Better, or Best mode. You can chocse
to turn it off for faster rendering.

Invisible Objects

This option, when on, allows you to quickly
see all invisible object that are currently in
your scene. This is particularly useful when
you're working with complex models that contain a
large number of invisible parent objects.

{nvisible

To see invisible objects:
¢ Inthe Rendering Control Panel, click the Invisible
button to toggle the setting on or off.

7.49

Window Size

The Window Size area of the Rendering Cantrol Panel
allows you to choose from a list of pre-defined window
size settings. You can also enter an exact width and
height (in pixels) in the boxes provided. The fock,
when checked, constrains the two dimensions.

Window Size | Custom |

width [407 —
— _@ || Apply

Height |332

To set a new window size:

1. Choose a pre-defined window size from the pop-
up or type in the exact height and width dimensions
you want.

2. Click Apply.

Outputting Your Scene

Once you have finished setting up your scene, you

are ready to either render a single image or make a
movie. LogoMotion allows you to save images using
the Save Image As command. You can also render

animations using the Make Movie command.

The following sections describe the details of saving

single images and making movies.

Saving a Single Image

You can save a moment in your animation as a single

image file. The image file formats available are:

*  On Macintosh: PICT, Compressed PICT, PICS,
TIFF, and QuickTime

e OnPCs: PSD, JPG, TIF, AVl, BMP, and various
other formats

To save a single image:

1. Choose File> Save Image As.

2. A standard Save dialog appears.

3. Type a name for your image, choose a location,

and pick the image file type you want.

4. Click OK.

Making a Movie

When you ready to render your entire animation,

you're ready to make a movie. Making a movie is

quite simple; you control the options for making the

movie in the Render Setup dialog. Waiting for the

movie to render takes time. How you set the various

options has an effect on the rendering time.

To make a movie:
1. Choose File> Make Movie.
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The Render Setup dialog appears.
2. Set the options you want, then click Render.
A standard Save dialog appears.

3. Specify a name, location, and file type for the
movie, then click OK.

Refer to “File Formats for Images and Animations” on
page 100 for more information on file types.

Rendering Options
The following sections describe the rendering options
you can set in the Render Setup dialog.

Quality

You can specify the type of rendering you want in the
Quality pop-up. You can choose from ail of
LogoMotion’s shading modes: Bounding Box,
Wireframe, Fast (Flat), Better (Gouraud), or Best
(Phong).

Renderer

You can choose the renderer you want LogoMotion to
use to render the animation. The MetaCreations
renderer produces the highest quality images, but
takes time to render. The QuickDraw 3D renderers
(called Best, SW and HW Interactive) take much less
time to render, but image quality may be poorer.

If you want to render using QuickDraw 3D and have a
QD3D accelerator card, choose HW Interactive. If not,
choose SW or Best Interactive.

Depth

The Depth pop-up allows you to specify the color
depth of the final rendering. You can choose from
black and white, 4, 16, 256, thousands or millions of
colors. As with all graphics programs, you should
consider how much RAM you have available when
determining the color depth.

Shadows

Click the Shadows checkbox if you want the
animation to be rendered with shadows. Rendering
shadows increases the overall rendering time. If
you're making a movie just to check object motion
and transformations, try rendering without shadows to
decrease your rendering time.

Alpha Channel

Click the Alpha Channel checkbox to have
LogoMotion render an alpha channel with your image.
This item is only available when you are rendering in
millions of colars. Alpha channels are extremely useful
for compositing multiple images together or
compositing computer graphics onto video. When this
option is checked, LogoMotion creates a "straight”
alpha channel.

When you use an alpha channel, images tend to
look jagged when viewed in programs that don't
support alpha channels.

Don’t Render Lights

Checking this option causes light objects in the scene
to become invisible. They still cast light, however, so
their effects on objects appear in the final render.
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Dithering

Checking this option dithers the images. Dithering is a
method used to trick the eye into seeing a greater
range of colors than are actually present in an image.
For images represented by fewer than 24 bits of color
per pixel, dithering can improve the image guality
dramatically.

Anti-aliasing

Anti-aliasing smoothes the edges of images, removing
the jagged appearance of diagonat lines. Although
anti-aliasing can be a time-consuming process, it can
produce an image of superior quality. Check this
opticn to have LogoMotion render images with
smoother edges.

Render Invisible Objects
The Render Invisible Objects option allows you to
render a scene that shows all the invisible objects.

Width and Height

The Width and Height settings allow you to enter the
precise width and height for your animation. This can
be set for either pixels, inches or centimeters. When
you choose inches, you can also type in your desired
dpi (dots per inch).

Constrain Proportions

When the Constrain box is checked, LogoMotion
keeps the aspect ratio of the width and height of the
rendered image. This is useful when you're creating a
large movie and don't want to shift the viewplane.
When LogoMotion resizes a window, it sometimes
shifts the viewplane as the aspect ratio changes. This
can cause your scene 1o shift within the window
slightly, something you may not want. To avoid this,
keep this box checked and let LogoMotion calculate
the second value to maintain the current aspect ratio.

Frames

You can chaose to render all the frames in an
animation, just the current frame, or you can choose a
starting point and an ending point.

Clicking the Current button selects only the frame on
which the World Time Marker is resting.

Rendering a range of frames lets you specify the
starting and ending point by typing the frame
numbers in the From and To fields. Or, you can use
the pop-ups next to the From and To fields to
determine the starting and ending points.

Frames Per Second (FPS)

This option allows you to specify the number of
frames per second at which the animation will be
rendered. For instance, if you are rendering a 3-
second animation at 30 frames per second, 90 frames
of animation are generated for the animation. If you
rendered the same animation at 20 frames per
second, the resulting number of frames rendered
would be 60. This option corresponds to the Frames
Per Second command in the Animate menu.




The Rendering Window

When you make a movie, LogoMotion displays a
Rendering window. The Rendering window displays
the scene, bit by bit, as it renders. When rendering is
complete, you can return to the Camera View by
choosing File> Exit. This is also a good way to stop a
rendering in progress.

File Formats for Images and Animations

You have a variety of formats for saving your rendered
images and animations. The various formats can be
used in other desktop publishing or multimedia
programs.

QuickTime™ Movie (Macintosh)

The default format for animations is a QuickTime
Movie file. QuickTime is a system extension
developed by Apple Computer that allows you to
compress animations to save disk space with varying
degrees of image quality.

Due to the nature of QuickTime and depending on the
type of machine and additional hardware you have,
the smoothness of the playback of your QuickTime
movies can vary considerably. Movies that are smaller
in image size and that contain less motion will be less
likely to be jumpy when played back.

Compression Settings
~~COMPIESS O oy

{"Animation ~]
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~Quality
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With QuickTime, you can choose various options
for compressing the movie file.

PIiCT (Macintosh)

PICT is one of the most widely recognized image file
formats on Macintosh computers. You can save
animations and single images in PICT format.

If you choose PICT as the file format when rendering
an animation, LogoMotion creates a series of
numbered PICT files as the output—one for each
frame of the animation.

Compressed PICT (Macintosh)

You can also choose to save rendered images as
Compressed PICT files, using QuickTime to achieve
the compression. QuickTime is a system extension
that allows you to compress PICT files to save disk
space with varying degrees of image quality.

if you choose this file format, you'tl be able to take
advantage of various options for compressing the
PICT file.
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PICS (Macintosh)

A PICS file is simply multiple PICT files stored into a
single document. You can set various options when
you choose this file format.

PICS files have a maximum size of 16 MB. You can
have LogoMotion set a maximum file size when
rendering to PICS so that the file doesn't exceed that
size. If LogoMotion reaches the maximum size while
rendering, it saves that PICS and creates a new PICS
numbered by frames.

TIFF (Macintosh and Windows)

You can save rendered images as TIFF files. This
format is popular with graphic artists, and is widely
used with page-layout and graphics software.

AVI (Windows)

AVlis a popular movie format for Windows. With AV,
many forms of compression are available to reduce
image sizes, though there may be trade-offs on image
quality versus file size. As not all compression
“codecs" are present on all computers, it's a good
idea to use Microsoft Video 1 compression if you are
unsure of the codecs installed on other machines.
Microsoft Video 1 compression is present on almost
all Windows 95 and Windows NT 4.0 computers.

PSD (Windows)

You can save images as PhotoShop documents from
within LogoMotion. You can then easily incorporate
the image into any of your PhotoShop projects.

BMP, JPG (Windows)

LogoMotion supports BMP, JPG, and many other
common Windows image file formats. Most of the
formats support various forms of compression that
save disk space by reducing file size. It is likely that
LogoMotion supports the image format you're
interested in using.




FREQUENTLY ASKED QUESTIONS

Question: Where are the hundreds of StageHands
that come with LogoMotion?

Answer: A few 'Starter’ StageHands are installed on
your hard drive when LogoMotion is installed. The rest
of the StageHands are found on the LogoMotion CD-
ROM. To gain access lo the hundreds of Cameras,
Lights, Props, and Backdrops on the LogoMotion CD,
replace the StageHands folder found in the
LogoMotion folder of the hard drive with the
StageHands folder found on the LogoMotion CD. This
will require about 100 MB of hard disk space. If there
is little free hard disk space, here's what you can do:

The StageHands folder on the CD contains folders of
Cameras, Lights, Props, and Backdrops. Within those
folders are more folders containing different
categories of StageHands. Simply copy the desired
category folders into the corresponding folder on the
hard disk and the new StageHands will appear in the
StageHands panel within LogoMotion.

Question: How can | use my own images as
background images?

Answer: Place them in the "Put Your Qwn Backdrops
Here" folder, which is located in the StageHands
folder. The next time LogoMotion is run, your image or
animation will appear in the StageHands panel and
can be dragged into your scene. On the Mac, PICT
and QuickTime files can be used as backdrops. On
Windows, BMP, JPG and other image files can be
used.

Question: How do | import an EPS file from
PhotoShop and lllustrator?

Answer: If you get a message in LogoMotion saying
that there are "no recognizable EPS operators® then
this question is for you. If you are attempting to save a
picture as an EPS file and bring it into LogoMotion, it
needs to be done a special way. Here's why: saving a
picture as an EPS file is the equivalent of putting a
picture into an EPS "envelope’, then giving this
envelope to LogoMotion and expecting the program
to pull the picture out of the envelope to make a 3D
object out of it. What you need to do instead is to use
your picture as a template and create outlines around
the edges of your picture. In PhotoShop, you woutd
use the selection tools and path tocls to come up with
your outline. After you've done that, you would do a
"File->Export->Paths to lllustrator” (you are not going
to lllustrator, but that's the kind of fite LogoMotion
wants to see). In illustrator, you would use the path
tools or "create outlines” command for text to create
the paths that LogoMotion wants.

Question: Why don‘t the texture maps on the
objects show up in my scene?

Answer: To see objects that have PICT images and
QuickTime movies texture mapped on to them, you
must be in Shade Best mode. Go to the Rendering
Control Panel Mode (command-6 on Mac, control-6
on Windows) and set the Quality to "Best.” Texture
Maps will not be rendered in any of the other
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rendering modes.

Question: Why don't my objects cast shadows?
Answer: To have a scene with shadows, you shouid
make sure of five items.

1) Your scene must be set to render in Shade Best in
the Rendering Control Panel mode (command-6 on
Mac, control-6 on Windows).

2) The Shadows button in the Rendering Panel must
be turned on.

3) Every object that you want to cast a shadow should
have its own Cast Shadows button turned to "On" in
the Object Information Control Panel (command-1 on
Mac, control-1 on Windows).

4) The QuickDraw 3D button in the Rendering Control
Panei is set to “Off". A light in your scene must also be
made to cast shadows. With the light selected choose
Edit Light under the Options menu and check the
Cast Shadows box. After all this, you should see
shadows in your scene. When rendering the final
movie of your animation, make sure the Shadows box
is checked in the Options menu of the Make Movie
dialog.

Question: How can | create an animation that can
be pasted onto a background in another
application?

Answer: You will mostly likely want to use an alpha
channel (see next question) to mask out the
background (Note: your background color must be
set to black to work properly). To create an alpha
channel for an existing scene, go to the File menu
and choose “Render Movie " In the Make Movie dialog
box, select Millions of Colors and check the Create
Alpha Channel box. Once you've done this, click on
the Render button. If you are going to render to a
QuickTime movie, click the Options button in the save
animation dialog, choose the animation compressor
with Millions of Colors+, and set the quality to High or
Most.

Question: What exactly is an alpha channel?
Answer: In a 32-bit image (millions of colors), 8 bits
are used for storing the red color information, 8 for
the green information, and 8 for the blue color
information. The remaining 8 bits can be used by
some applications (such as Adobe Premiere and
Avid Videoshop) to store masking information for
compaositing images together. A common use is to
layer graphics over a background or an animation
over live video. The alpha channel is used to store
the anti-aliasing information so that the composite is
seamless. )




Question: Why is my extrude object hollow when |
expect it to be solid?

Answer: The outline for this object may not be closed.
in the extrude workshop, you can connect the points
using by first choosing Snap To Grid from the Points
menu. Now drag one of the points to any location on
the grid, and then drag the second point to this same
location. Your points are effectively joined, but to turn
the two overlapping points in to one point, choose
*Join Points” from the Object menu. Once the object
no longer appears hollow in the Object window, leave
the workshop and your object should be solid

Question: How can | make an object appear or
disappear during an animation?

Answer: Since objects exist throughout the entire
animation, making an object suddenly appear can be
done in one of three ways. The first way is to position
the object outside the camera view at the beginning
of your animation and then later moving the object
into the camera view. The second way is to shrink the
object down to a Uniform Scale of 0.001 in the Object
Information Panel Mode at the beginning of the
animation and then later enlarging the object to a
visible size. Since the object's position/size will
change over time from one eventmark to the next, the
time for this change to occur depends on the time
between eventmarks. For example, if there are two
seconds between eventmarks, then the object will
take two seconds to move into view or to grow from
nothing to full size. If the eventmarks are only one
frame apart, this transition will be instantaneous. To
make an object disappear, simply make the object
visible at the beginning of the animation and later
move the object out

Question: Why do the QuickTime movies | produce
with LogoMotion have choppy playback?

Answer: How smoothly your movies play will depend
on such factors as the type of machine you are
running on, if you have any additional hardware
support, the screen size and file size of your movie,
the frame rate, the movie compression type, and the
amount of RAM allocated to the movie-playing
application. QuickTime, by nature, will have jerky
playback on most machines without some sort of
hardware support to help it. In the absence of extra
hardware, your best bet is to keep your movies to
320x240 or smaller in size (keeping the image size to
a division of four will help too), playing at 20 to 15
frames per second with medium animation
compression.

Question: | am using a Power3D accelerator card
and objects look and move strangely. Why?
Answer: There are conflicts with LogoMotion and
Power3D accelerator cards. While the two products
may work more nicely together in the future, currently
we recommend disabling or removing the Power3D
drivers (3dfx RAVE and 3dfxGlideLib2.x ) when using
LogoMotion.

Question: Text is missing in LogoMotion's panels,
and the text that is visible is very large. What
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causes this?

Answer: You are most likely have the "Large Fonts’
setting enabled on your Windows 95 or NT machine.
We recommend choosing the "Small Fonts" option
found in the Settings panel of the Display Control
panel.

Question: How can | make my own StageHands
show animated previews on another computer?
Answer: On a Macintosh, StageHand previews should
always play. On windows, we recommend using
"Microsoft Video 1" compression when saving custom
StageHand files. This is a movie compressor that is
included with every Windows 95 and NT 4 aperating
system. I you use other compressors, other
computers must have the compressor you used in
order to show the StageHand preview. Don't worry if a
StageHand's preview doesn't animate—it will still work
fine.




